Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39130 - [kdesdk-kcachegrind] hotshot2calltree crashes on load due to invalid version string

Attached to Project: Arch Linux
Opened by Henry de Valence (hdevalence) - Monday, 03 March 2014, 21:14 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 04 March 2014, 14:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The hotshot2calltree script included in kdesdk-kcachegrind 4.12.2-1 crashes on launch due to an invalid version string.

Specifically, line 56 has:

version = "$Revision$"

and line 347 has:

versiontext = "%s version: %s" % ( progname, version.split()[1], )

which causes a crash because "$Revision$" hasn't been replaced with the actual version string.

Additional info:
* package version(s)

/usr/bin/hotshot2calltree is owned by kdesdk-kcachegrind 4.12.2-1

* config and/or log files etc.

None.

Steps to reproduce:

Run the program.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 04 March 2014, 14:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdesdk-kcachegrind 4.12.3-1
Comment by Andrea Scarpino (BaSh) - Monday, 03 March 2014, 21:53 GMT
Please report this upstream
Comment by Henry de Valence (hdevalence) - Monday, 03 March 2014, 22:21 GMT
Thanks, I've reported it here: https://bugs.kde.org/show_bug.cgi?id=331715

Loading...