Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39021 - [linux] 3.13.x - new module 'huawei-cdc-ncm' - can't connect with 3G Stick E3276 / K5150 anymore

Attached to Project: Arch Linux
Opened by Manfred Miederer (LessWire) - Monday, 24 February 2014, 02:27 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Thursday, 20 March 2014, 05:57 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The Huawei E3276 is a widely used premium 3G(4G) usbstick for LTE/UMTS etc. It's identical to the Vodafone K5150 in a technical view and with previous kernel versions it worked always fine.

3.14. comes up with a new module 'huawei-cdc-ncm'. It offers NCM as a transport for other protocols, usually an embedded AT channel especially for Huawei sticks.

This module is loaded automatically and brings up the needed wwan0 interface. But dhcpcd can't communicate with the stick anymore, i didn't get any provider data.

I tried to blacklist this module because in previous kernel versions it runs standalone with 'cdc-ncm' only, but this doesn't bring up a wwan0 interface.

Steps to reproduce:
Try it with this stick ;)
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Thursday, 20 March 2014, 05:57 GMT
Reason for closing:  Upstream
Additional comments about closing:  Will be fixed in 3.14
Comment by Manfred Miederer (LessWire) - Monday, 24 February 2014, 18:46 GMT
ID of the stick is: 12d1:1506
Comment by Gerhard Bogner (slashME) - Thursday, 27 February 2014, 01:27 GMT
I'm having the same problem with a the Huawei E3272, which is switched to the same ID using usb_modeswitch.

The NCM interface works well on my Raspberry Pi using the 3.10.32-1-ARCH kernel: 'echo "at^ndisdup=1,1" > /dev/ttyUSB0' (where ttyUSB0 is the PCUI port) tells the stick to connect, and results in a kernel message that wwan0 was connected. The IP address can then be acquired using dhcp.

In 3.13 sending the at command to /dev/cdc-wdm0 seems to work as well (and the modem responds with 'OK' and later '^ndisstat:...'), but the wwan device is never 'connected' and all dhcp requests time out.

There already seems to be a discussion about this problem at http://www.spinics.net/lists/linux-usb/msg97112.html
Comment by Manfred Miederer (LessWire) - Thursday, 20 March 2014, 04:43 GMT
I just have seen in the mailing list that this problem will be solved with kernel 3.14.

Loading...