Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39010 - [libgdiplus] doesn't build

Attached to Project: Arch Linux
Opened by Paul Burton (paulburton) - Sunday, 23 February 2014, 17:34 GMT
Last edited by Jan de Groot (JGC) - Monday, 17 November 2014, 18:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: libgdiplus 2.10.9-3 fails to build with the current version of freetype2 (2.5.2-1) due to a change in freetype header location:

libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/freetype2 -Wall -Wno-unused -Wno-format -D_FORTIFY_SOURCE=2 -mips32r2 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -pthread -MT adjustablearrowcap.lo -MD -MP -MF .deps/adjustablearrowcap.Tpo -c adjustablearrowcap.c -fPIC -DPIC -o .libs/adjustablearrowcap.o
In file included from adjustablearrowcap-private.h:38:0,
from adjustablearrowcap.c:25:
gdiplus-private.h:33:31: fatal error: freetype/tttables.h: No such file or directory
#include <freetype/tttables.h>
^
compilation terminated.
make[2]: *** [adjustablearrowcap.lo] Error 1
make[2]: Leaving directory


Debian have a patch for this: http://patch-tracker.debian.org/patch/series/view/libgdiplus/2.11+git20131008.9732566-4/use_freetype_macros.patch
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 17 November 2014, 18:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed long time ago.
Comment by mattia (nTia89) - Monday, 17 November 2014, 14:37 GMT
I can't reproduce the bug: libgdiplus 3.8-1 build fine for me.

Loading...