Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39 - when start a nautilus window, sawfish crashed

Attached to Project: Arch Linux
Opened by Bald Zhang (baldzhang) - Sunday, 23 February 2003, 23:57 GMT
Last edited by Dale Blount (dale) - Thursday, 12 June 2003, 19:33 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Dale Blount (dale)
Architecture All
Severity Very Low
Priority Normal
Reported Version 0.6 Widget
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

when i open a nautilus window, such as root's home or trash, the sawfish will crash, sometimes, gnome-panel also,
i install arch in VirtualPC, which from contectix. before install any package, i install all it's dependances.
is i do something wrong or just a bug?
This task depends upon

Closed by  Anonymous Submitter
Thursday, 12 June 2003, 19:33 GMT
Reason for closing:  
Comment by Sean Middleditch (elanthis) - Monday, 24 February 2003, 01:24 GMT
Does this only happen with Sawfish? Can you try it with Metacity or another GNOME compliant WM?

Also, are you running any non-standard applet on your panel? A lot of the third-party ones are known for reducing stability a lot.
Comment by Bald Zhang (baldzhang) - Monday, 24 February 2003, 02:40 GMT
after a lot of test
1.metacity is ok
2.except gnome menu panel, if there is addtional panel(even a empty panel), sawfish will crash when i open root's home, trash and mounted floder from desktop
2.build sawfish-1.2 from source will crash too

thanks to elanthis
Comment by Sean Middleditch (elanthis) - Monday, 24 February 2003, 02:45 GMT
two things:

a) Sawfish sucks. Metacity is official GNOME WM now.
b) if you have GTK2.2 installed, downgrade to GTK2.0. GNOME2.0 and GTK2.2 don't play together nicely, and someone decided to upload GTK2.2 without fixing libgnomeui.

I'll hopefully have GNOME2.2 up very soon tho, that'll fix it as well.
Comment by Sean Middleditch (elanthis) - Sunday, 02 March 2003, 22:11 GMT
gnome2.2 is up. please test using it (and metacity, not sawfish), and lemme know if it works for you now.
Comment by Bald Zhang (baldzhang) - Tuesday, 04 March 2003, 07:05 GMT
yes, i test it.
sawfish still has the problem :(
metacity is fine.

gnome-terminal, gnome-theme-manager not work
in nautils, when open Edit -> Backgrounds and Emblems, it will crash immediately and then restart, nautils lost all it's icons config, all files and folders looks the same with each other

gtk2 bluecurve theme not work because theme engine not found, after copy /usr/lib/gtk-2.0/2.0.0/engines/libbluecurve* to /usr/lib/gtk-2.0/2.2.0/engines, i resolve it.

other problem, nautilus's smb:/// has a bug(?), i have 2 smb server in my windows workgroup, one is win-xp named 'beld' and other is run samba 2.2.4 on slackware 8.1 named 'beldlinux', when i open smb://workgroupname in nautilus, it just display to workstation named the same "beldlinux", and i know this not occurs in redhat 8.0.94
Comment by Sean Middleditch (elanthis) - Tuesday, 04 March 2003, 14:37 GMT
OK, for Sawfish, I can't support that very well - it's no longer a part of GNOME. Does it at least work on its own? (Without GNOME)

The gnome-terminal crash is a known problem. Still working to resolve it. I'll look into the theme manager problem tho.

For the old theme engines, you should probably recompile them; there may be incompatibilities between an engine compiled for gtk2.0 and gtk2.2 (which is why it looks for the engines in a different directory on each version).

I'll take a look at the smb:// problem as well - I don't recall having any problems, but maybe I can reproduce the error.
Comment by Judd Vinet (judd) - Friday, 06 June 2003, 17:10 GMT
Moving this on to Dale.

Dale: I don't know if this bug is still valid or not. If it isn't please close it.
Comment by Dale Blount (dale) - Saturday, 07 June 2003, 19:25 GMT
baldzhang Please comment if this bug still exists for you if you 'pacman -Syu' first.

Comment by Bald Zhang (baldzhang) - Monday, 09 June 2003, 01:19 GMT
i apologize for busy now, because some problem in my work an i can not test it recently. :(

i'll do it as soon as i can.
Comment by Dale Blount (dale) - Monday, 09 June 2003, 15:41 GMT
gnome-terminal updated to 2.2.2
Comment by Dale Blount (dale) - Thursday, 12 June 2003, 19:33 GMT
  • Task details edited
baldzhang, I'm closing the bug in the mean time, please re-open if you find that it still exists.

Loading...