Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38952 - [udisks] Udisks-daemon random 100% CPU usage

Attached to Project: Arch Linux
Opened by mkkot (mkkot) - Tuesday, 18 February 2014, 09:06 GMT
Last edited by Laurent Carlier (lordheavy) - Sunday, 09 March 2014, 13:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I'm dealing with problem that in some cases, randomly, udisks-daemon can take 100% of one CPU core and stops only when I kill it. After doing that, I can't halt my system because systemd leaves me on blank screen, the discs are shut down but I still can hear fans running and power led is light.

I found here: https://forums.gentoo.org/viewtopic-p-6472936.html#6472936
that it can be a problem with locale.

There is a post which suggests that the problem occurs when user is not having quote mark at the first line of the locale:

[root@linux mk]# locale
LANG=pl_PL.UTF-8 << missing "quote" mark
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
[...]

Archlinux wiki https://wiki.archlinux.org/index.php/locale

says that cat /etc/locale.conf should be
LANG="pl_PL.UTF-8"

which produces the output as given in locale command. Could it be the problem? Or should I report upstream?



Additional info:
* package version(s)
* config and/or log files etc.

Messages which appeared in journalctl when udisks-daemon hanged up:

lut 18 09:30:51 linux udisks-daemon[301]: **** Refreshing ATA SMART data for /sys/devices/pci0000:00/0000:00:08.0/ata1/host0/target0:0:0/0:0:0:0/block/sda
lut 18 09:30:52 linux udisks-daemon[301]: helper(pid 1868): launched job udisks-helper-ata-smart-collect on /dev/sda
lut 18 09:30:52 linux udisks-daemon[301]: **** Refreshing ATA SMART data for /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb
lut 18 09:30:52 linux udisks-daemon[301]: helper(pid 1869): launched job udisks-helper-ata-smart-collect on /dev/sdb
lut 18 09:30:52 linux udisks-daemon[301]: helper(pid 1868): completed with exit code 0
lut 18 09:30:52 linux udisks-daemon[301]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:08.0/ata1/host0/target0:0:0/0:0:0:0/block/sda

I mounted and unmnounted /dev/sdb thinking this could cause the problem:

lut 18 09:35:14 linux su[2030]: (to root) mk on pts/0
lut 18 09:35:14 linux su[2030]: pam_unix(su:session): session opened for user root by mk(uid=1000)
lut 18 09:35:20 linux kernel: XFS (sdb5): Mounting Filesystem
lut 18 09:35:20 linux udisks-daemon[301]: **** /proc/self/mountinfo changed
lut 18 09:35:20 linux udisks-daemon[301]: **** MOUNTED /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:20 linux udisks-daemon[301]: **** CHANGING /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:20 linux udisks-daemon[301]: **** UPDATING /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:20 linux udisks-daemon[301]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:20 linux udisks-daemon[301]: **** CHANGED /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:20 linux kernel: XFS (sdb5): Ending clean mount

Then I killed udisks-daemon:

lut 18 09:35:27 linux udisks-daemon[301]: **** /proc/self/mountinfo changed
lut 18 09:35:27 linux udisks-daemon[301]: **** UNMOUNTED /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:27 linux udisks-daemon[301]: **** CHANGING /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:27 linux udisks-daemon[301]: **** UPDATING /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:27 linux udisks-daemon[301]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:27 linux udisks-daemon[301]: **** CHANGED /sys/devices/pci0000:00/0000:00:08.1/ata3/host2/target2:0:0/2:0:0:0/block/sdb/sdb5
lut 18 09:35:27 linux org.gtk.Private.UDisks2VolumeMonitor[407]: ### debug: emit_signal: 0x1447470
lut 18 09:35:27 linux org.gtk.Private.UDisks2VolumeMonitor[407]: ### debug: emit_signal: 0x149b0f0
lut 18 09:35:27 linux org.gtk.Private.UDisks2VolumeMonitor[407]: ### debug: emit_signal: 0x149b0f0


Steps to reproduce:

Unknown. It happens even if PC is playing music and nothing is done on it.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Sunday, 09 March 2014, 13:24 GMT
Reason for closing:  None
Additional comments about closing:  close request by the poster
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 18 February 2014, 14:17 GMT
  • Field changed: Summary (Udisks-daemon random 100% CPU usage → [udisks] Udisks-daemon random 100% CPU usage)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Field changed: Category (Packages: Core → Upstream Bugs)
  • Task assigned to Tom Gundersen (tomegun)
Please report to upstream.
Comment by Jan de Groot (JGC) - Wednesday, 19 February 2014, 10:29 GMT
quotes shouldn't be an issue, locales without spaces or wildcards don't have to be quoted.

Which version of glibc do you use? 2.19-2 fixed an issue with locale generation which could result in a corrupted locale archive, maybe this also affects your bug.
Comment by mkkot (mkkot) - Thursday, 20 February 2014, 12:27 GMT
Thanks for the answer. I have the newset version since
[2014-02-15 01:03] [PACMAN] upgraded glibc (2.19-1 -> 2.19-2)
I'll look into this problem closer since I just discovered that my system battery is below 3V. Maybe this can be the reason. You can close the bug for now.

Loading...