Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38914 - [wxgtk] missing dependency on webkitgtk2

Attached to Project: Arch Linux
Opened by Moritz Bunkus (mbunkus) - Friday, 14 February 2014, 15:32 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 14 February 2014, 15:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Some libraries installed with wxgtk 3.0.0 are linked against libwebkitgtk2….so, but the wxgtk package doesn't depend on the webkitgtk2 package (which contains libwebkitgtk2*.so). This is a real problem because linking against those libraries doesn't work, obviously, and this is made worse by those libraries being part of the output of `wx-config --libs std`.

For example:

[0 mbunkus@chai-latte ~] wx-config --libs std
-pthread -lwx_gtk2u_xrc-3.0 -lwx_gtk2u_webview-3.0 -lwx_gtk2u_html-3.0 -lwx_gtk2u_qa-3.0 -lwx_gtk2u_adv-3.0 -lwx_gtk2u_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0
[0 mbunkus@chai-latte ~] ldd /usr/lib/libwx_gtk2u_webview-3.0.so|grep -i 'not found'
libwebkitgtk-1.0.so.0 => not found


Additional info:
* package version(s): wxgtk 3.0.0-2



Steps to reproduce:

Install wxgtk. Remove webkitgtk2 if it is present (which will be allowed). Try to compile an application against wxWidgets that uses the recommended way of detecting the libraries, which is the `wx-config --libs …` line shown above. MKVToolNix is such a package: configure will fail to detect wxWidgets support.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 14 February 2014, 15:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Optional Deps : webkitgtk2: for webview support

Loading...