Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38906 - [libetpan] Links libetpan.so.16 lost

Attached to Project: Arch Linux
Opened by lesebas (lesebas) - Thursday, 13 February 2014, 20:34 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 13 February 2014, 21:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Since the update to version 1.2.1 the applet mail in "Cairo-dock" doesn't work so far. It's because the applet call explicitly the link libetpan.so.16. As the library move to libetpan.17.0.0 I have adedd a symlink libetpan.so.16 to libetpan.so.17.0.0. I don't know if we can consider this as a bug from libetpan or cairo-dock (bug reported to the dev of cairo-dock too http://www.glx-dock.org/bg_topic.php?t=7622&pos=0#mess_82663 ).

Maybe added the link by default could insure the compatibility between versions?
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 13 February 2014, 21:02 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User error. AUR packages are your responsibility.
Comment by Dave Reisner (falconindy) - Thursday, 13 February 2014, 20:49 GMT
cairo-dock-plugins was correctly rebuilt against the new soname:

$ readelf -d /usr/lib/cairo-dock/libcd-mail.so | grep libet
0x0000000000000001 (NEEDED) Shared library: [libetpan.so.17]

So... Did you upgrade to cairo-dock-plugins-3.3.2-2 ?
Comment by lesebas (lesebas) - Thursday, 13 February 2014, 20:53 GMT
I'm using the bzr version...
Comment by Dave Reisner (falconindy) - Thursday, 13 February 2014, 21:01 GMT
Then it's your own responsibility to rebuild the package against the new soname for libetpan. There's no bug here.

Loading...