Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38878 - [libreoffice-kde4] Libreoffice crashes when I do a "save as"

Attached to Project: Arch Linux
Opened by patrick (potomac) - Wednesday, 12 February 2014, 01:34 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Wednesday, 12 February 2014, 02:38 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
when I use libreoffice ( calc, writer for example ) it crashes when I do a "save as" ( saving a document ),

the bug doesn't happen all the time, it's a random bug, but the bug happens very often,

in the console I can read :

QWidget::repaint: Recursive repaint detected

I have KDE 4.12.2, archlinux 64 bits, system up to date

it's a similar bug like this :

https://bugzilla.redhat.com/show_bug.cgi?id=988643

Additional info:
* package version(s) libreoffice 4.1.5-1 , qt5-base 5.2.1-1, qt4 4.8.5-7, kde 4.12.2-1

* config and/or log files etc.


Steps to reproduce:
- install libreoffice
- install KDE ( but the bug may occur in a gnome environnement, but I'm not sure )
- open calc ( or writer ), create a document
- save the document
- when the mouse is on the "save" button the program will crash and you will see this error message on the console :
QWidget::repaint: Recursive repaint detected

if the bug does not occur the first time : repeat the steps two or three times, the bug will occur
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Wednesday, 12 February 2014, 02:38 GMT
Reason for closing:  Won't fix
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 12 February 2014, 01:37 GMT
4.1.4 works fine? without libreoffice-kde4 works fine?
Comment by patrick (potomac) - Wednesday, 12 February 2014, 01:58 GMT
the bug occurs also with libreoffice 4.1.4 ( the first time I detected this bug it was with 4.1.4 version, then I tried 4.1.5, the bugs still occurs )

but if I uninstall "libreoffice-kde4" package the bug is gone !

so the problem is the "libreoffice-kde4" package, something is wrong with this package,

the workaround is to uninstall "libreoffice-kde4", but it would be great if someone can find a solution
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 12 February 2014, 02:35 GMT
  • Field changed: Summary ([libreoffice] Libreoffice crashes when I do a "save as" → [libreoffice-kde4] Libreoffice crashes when I do a "save as")
  • Field changed: Category (Packages: Extra → Upstream Bugs)
  • Field changed: Severity (Critical → High)
OK as suspected. This should gone when 4.2 hit repos. See  FS#37980 .

Loading...