Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38830 - dhcpcd-6.2.1-1 eth0 get no ip

Attached to Project: Arch Linux
Opened by Udo (doenerknall) - Friday, 07 February 2014, 17:34 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 07 February 2014, 17:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
On Raspberry Pi eth0 dont get IP after upgrading dhcpcd to dhcpcd-6.2.1-1-armv6h.pkg.tar.xz.
After downgrading to dhcpcd-6.1.0-1.1-armv6h.pkg.tar.xz everything looks fine.

Jan 1 01:13:05 localhost systemd[1]: Stopping system-dhcpcd.slice.
Jan 1 01:13:05 localhost systemd[1]: Removed slice system-dhcpcd.slice.
Jan 1 01:00:23 localhost dhcpcd[145]: DUID 00:01:00:01:c7:92:bc:95:b8:27:eb:73:66:2e
Jan 1 01:00:23 localhost dhcpcd[145]: eth0: IAID eb:73:66:2e
Jan 1 01:00:23 localhost dhcpcd[145]: eth0: soliciting a DHCP lease
Jan 1 01:00:23 localhost dhcpcd[145]: eth0: carrier lost
Jan 1 01:00:24 localhost dhcpcd[145]: eth0: carrier acquired
Jan 1 01:00:24 localhost dhcpcd[145]: eth0: IPv6 kernel autoconf disabled
Jan 1 01:00:24 localhost dhcpcd[145]: eth0: IAID eb:73:66:2e
Jan 1 01:00:24 localhost dhcpcd[145]: eth0: soliciting a DHCP lease
Jan 1 01:00:24 localhost dhcpcd[145]: eth0: offered 192.168.178.37 from 192.168.178.1
Jan 1 01:00:25 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:28 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:33 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:38 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:43 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:47 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:51 localhost dhcpcd[145]: eth0: reject NAK via 192.168.178.1
Jan 1 01:00:53 localhost dhcpcd[145]: exited
Jan 1 01:01:01 localhost dhcpcd[397]: version 6.2.1 starting
Jan 1 01:01:01 localhost dhcpcd[397]: exited
Jan 1 01:01:07 localhost dhcpcd[399]: version 6.2.1 starting
Jan 1 01:01:12 localhost dhcpcd[399]: all: IPv6 kernel autoconf disabled
Jan 1 01:01:14 localhost dhcpcd[399]: eth0: IPv6 kernel autoconf disabled
Jan 1 01:00:53 localhost systemd[1]: dhcpcd@eth0.service: control process exited, code=exited status=1
Jan 1 01:00:53 localhost systemd[1]: Unit dhcpcd@eth0.service entered failed state.
Jan 1 01:01:24 localhost dhcpcd[399]: eth0: reject NAK via 192.168.178.1
Jan 1 01:01:29 localhost dhcpcd[399]: eth0: reject NAK via 192.168.178.1debug2: channel 0: window 999037 sent adjust 49539

Jan 1 01:01:32 localhost dhcpcd[399]: eth0: reject NAK via 192.168.178.1
Jan 1 01:01:37 localhost dhcpcd[399]: eth0: reject NAK via 192.168.178.1
Jan 1 01:01:42 localhost dhcpcd[399]: eth0: reject NAK via 192.168.178.1
Jan 1 01:01:45 localhost dhcpcd[399]: exited
Jan 1 01:03:01 localhost dhcpcd[531]: version 6.2.1 starting
Jan 1 01:03:01 localhost dhcpcd[531]: exited
Jan 1 01:05:22 localhost dhcpcd[539]: version 6.1.0 starting
Jan 1 01:05:22 localhost dhcpcd[539]: all: IPv6 kernel autoconf disabled
Jan 1 01:05:22 localhost dhcpcd[539]: eth0: IPv6 kernel autoconf disabled
Jan 1 01:05:23 localhost dhcpcd[539]: eth0: soliciting a DHCP lease
Jan 1 01:05:23 localhost dhcpcd[539]: eth0: offered 192.168.178.37 from 192.168.178.1
Jan 1 01:05:28 localhost dhcpcd[539]: eth0: leased 192.168.178.37 for 864000 seconds
Jan 1 01:05:28 localhost dhcpcd[539]: eth0: adding host route to 192.168.178.37 via 127.0.0.1
Jan 1 01:05:28 localhost dhcpcd[539]: eth0: adding route to 192.168.178.0/24
Jan 1 01:05:28 localhost dhcpcd[539]: eth0: adding default route via 192.168.178.1
Jan 1 01:05:29 localhost dhcpcd[539]: forked to background, child pid 632
Feb 7 18:16:41 localhost systemd[1]: Stopping system-dhcpcd.slice.
Feb 7 18:16:41 localhost systemd[1]: Removed slice system-dhcpcd.slice.
Jan 1 01:00:15 localhost dhcpcd[144]: eth0: rebinding lease of 192.168.178.37
Jan 1 01:00:15 localhost dhcpcd[144]: eth0: carrier lost
Jan 1 01:00:16 localhost dhcpcd[144]: eth0: carrier acquired
Jan 1 01:00:16 localhost dhcpcd[144]: eth0: IPv6 kernel autoconf disabled
Jan 1 01:00:16 localhost dhcpcd[144]: eth0: rebinding lease of 192.168.178.37
Jan 1 01:00:21 localhost dhcpcd[144]: eth0: leased 192.168.178.37 for 864000 seconds
Jan 1 01:00:21 localhost dhcpcd[144]: eth0: adding host route to 192.168.178.37 via 127.0.0.1
Jan 1 01:00:21 localhost dhcpcd[144]: eth0: adding route to 192.168.178.0/24
Jan 1 01:00:21 localhost dhcpcd[144]: eth0: adding default route via 192.168.178.1
Jan 1 01:00:22 localhost dhcpcd[144]: forked to background, child pid 402
Jan 1 01:00:22 localhost systemd[1]: Started dhcpcd on eth0.

This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 07 February 2014, 17:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Wrong place. Ask in http://archlinuxarm.org

Loading...