Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38791 - [openssh] case sensitive Host fix

Attached to Project: Arch Linux
Opened by Ike Devolder (BlackEagle) - Tuesday, 04 February 2014, 21:04 GMT
Last edited by Gaetan Bisson (vesath) - Wednesday, 05 February 2014, 05:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the introdcution of openssh 6.5p1 you can no longer use 'Host
MyHost' in your .ssh/config .

There is a fix[1] suggested for it which needs some adaptation to apply
on 6.5p1[2] on the openssh mailinglist after reporting it[3].

It would be nice to have this patch applied since it might break other
users ssh workflow too.

[1] http://lists.mindrot.org/pipermail/openssh-unix-dev/2014-February/032173.html
[2] http://lists.mindrot.org/pipermail/openssh-unix-dev/2014-February/032176.html
[3] http://lists.mindrot.org/pipermail/openssh-unix-dev/2014-February/032168.html


Additional info:
* package version(s)
* config and/or log files etc.

openssh 6.5p1

sample config:

Host MyHost
Hostname 192.168.0.1
Port 1234
User root
IdentityFile ~/.ssh/id_rsa

Steps to reproduce:
This task depends upon

Closed by  Gaetan Bisson (vesath)
Wednesday, 05 February 2014, 05:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  openssh-6.5p1-2 in [testing]
Comment by Ike Devolder (BlackEagle) - Tuesday, 04 February 2014, 21:05 GMT
I'm already using a package with the patch so i dont have to change too many config entries

Loading...