Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38760 - [maxima] 5.32.1 can't refresh gnuplots

Attached to Project: Arch Linux
Opened by David López (David López) - Saturday, 01 February 2014, 19:27 GMT
Last edited by Ronald van Haren (pressh) - Thursday, 02 October 2014, 13:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I use 64 bits arch with wxmaxima 13-04.2-2 and gnuplot 4.6.4-5. I've recently updated maxima to 5.32.1-1 and I've noticed a bug when plotting in wxmaxima. For example

(%i1) plot2d(sin(x),[x,0,2*%pi]);
(%o1) "/home/david/maxout.gnuplot_pipes"

opens a gnuplot window with the sin function as usual, but

(%i2) plot2d(cos(x),[x,0,2*%pi]);
(%o2) "/home/david/maxout.gnuplot_pipes"

doesn't refresh the gnuplot window, it shows sin() instead of cos(). Moreover, if I close the gnuplot window and re-execute

(%i3) plot2d(cos(x),[x,0,2*%pi]);
(%o3) "/home/david/maxout.gnuplot_pipes"

it doesn't open a new gnuplop window. I have to close and restart wxmaxima.

I'm suffering this problem since I updated maxima to 5.32.1-1 in my 3 different machines. I've asked a friend with maxima 5.32.1/wxmaxima 13.04.2 in debian and he doen't suffer the bug, so is I think it's Arch specific

Additional info:
* Versions: maxima 5.32.1-1, wxmaxima 13-04.2-2 and gnuplot 4.6.4-5
* Plotting with wxplot2d works fine

Steps to reproduce:
* Open wxmaxima and execute kn a cell plot2d(sin(x),[x,0,2*%pi]);, execute plot2d(cos(x),[x,0,2*%pi]); in a different cell, close the gnuplot window and re-execute plot2d(cos(x),[x,0,2*%pi]);
This task depends upon

Closed by  Ronald van Haren (pressh)
Thursday, 02 October 2014, 13:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed by upstream in 5.34.0
Comment by Lev Cohan (lev) - Monday, 24 February 2014, 00:35 GMT
still persists for maxima 5.32.1-2
Comment by Ronald van Haren (pressh) - Sunday, 13 April 2014, 09:16 GMT
I can still replicate it with 5.33.0 and gnuplot 4.6.5.

Can you open a bug report upstream. We don't patch either maxima or gnuplot, so don't think this is a packaging bug we introduce. Maybe it is version specific or debian fixes it with some patch that is not upstream. Please post a link to the upstream bug report here.
Comment by David López (David López) - Sunday, 13 April 2014, 15:35 GMT
Thanks Ronald. I'm not sure if the problem is from maxima or gnuplot, I've just open a ticket in both

maxima: https://sourceforge.net/p/maxima/bugs/2721/

gnuplot: https://sourceforge.net/p/gnuplot/bugs/1379/
Comment by Lev Cohan (lev) - Thursday, 02 October 2014, 13:26 GMT
This problem has been fixed upstream and maxima 5.34.0-1 refreshes the gnu plot window again.
Comment by Ronald van Haren (pressh) - Thursday, 02 October 2014, 13:28 GMT
Thanks for the notice -> closing.

Loading...