Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38759 - [i8kutils] i8kmon fails to start without acpitool installed

Attached to Project: Arch Linux
Opened by Adrian (adirat) - Saturday, 01 February 2014, 16:01 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 01 February 2014, 21:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Version 1.40 of i8kmon fails to start because it doesn't find /usr/bin/acpitool. After installing https://aur.archlinux.org/packages/acpitool/ it works as expected.

In the 1.41 changelog at [1], the debian devs did some work on probing for acpi/acpitools, maybe an update to 1.41 fixes this? Is 1.41 out yet?

Before v1.40, i8kmon worked by having just acpi installed.

Additional info:
* package version 1.40
* [1] changelog for 1.41 http://bazaar.launchpad.net/~vitorafsr/i8kutils/trunk/view/head:/debian/changelog

Steps to reproduce:
* Run i8kmon while acpitools is not installed.
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 01 February 2014, 21:57 GMT
Reason for closing:  Fixed
Comment by Adrian (adirat) - Saturday, 01 February 2014, 16:08 GMT
This is the commit which handles probing for acpi/acpitools in 1.41 http://bazaar.launchpad.net/~vitorafsr/i8kutils/trunk/revision/19

If 1.41 is not out yet, maybe a patch is needed or acpitools added as a dependency?
Comment by Eric Belanger (Snowman) - Saturday, 01 February 2014, 17:00 GMT
acpitools was removed from repos because it was unmaintained upstream. I'll probably patch it since 1.41 doesn't seem to be out yet.
Comment by Eric Belanger (Snowman) - Saturday, 01 February 2014, 19:37 GMT
It should be fixed in i8kutils-1.40-2 (I've patched it). Can you try it and let me know how it goes? I don't have the hardware so I can't test it.
Comment by Adrian (adirat) - Saturday, 01 February 2014, 20:15 GMT
I removed the acpitool package and upgraded i8kutils to 1.40-2.
The acpitool not found error does not appear anymore, but there's a new error, its the output http://pastebin.com/h8B2Ept6
The output error is the same if I run i8kmon as root or user, or if it is from systemd service or console cmd.
Comment by Eric Belanger (Snowman) - Saturday, 01 February 2014, 21:27 GMT
Please try i8kutils-1.40-3
Comment by Adrian (adirat) - Saturday, 01 February 2014, 21:54 GMT
It works flawlessly now :) Thank you

Loading...