Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38698 - valgrind to run 32bit apps on x64 arch

Attached to Project: Arch Linux
Opened by Tomasz Mikolajczyk (tomaszmi) - Tuesday, 28 January 2014, 08:05 GMT
Last edited by Allan McRae (Allan) - Tuesday, 28 January 2014, 11:15 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Currently the x86_64 version of valgrind is not able to run 32bits applications due to a --enable-only64bit flag used when running ./configure script during valgrind building process. I'm not sure what was the motivation to disable this functionality but it would be good to be able to run 32bits apps as well. Is it possible to enable this feature?

Additional info:
* package version: 3.9.0-1

Steps to reproduce:
$ echo "int main(int, char**) {}" | g++ -m32 -x c++ - && valgrind ./a.out
valgrind: failed to start tool 'memcheck' for platform 'x86-linux': No such file or directory
$
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 28 January 2014, 11:15 GMT
Reason for closing:  Won't implement
Additional comments about closing:  See comment
Comment by Allan McRae (Allan) - Tuesday, 28 January 2014, 11:15 GMT
There would need to be a valgrind-multilib added to the [multilib] repo where the multilib toolchain resides as our [core] and [extra] repos are pure 64 bit.

Loading...