Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38694 - [octave] Support for experimental GUI editor missing

Attached to Project: Arch Linux
Opened by Martin Roth (Captain_Rage) - Monday, 27 January 2014, 23:34 GMT
Last edited by Ronald van Haren (pressh) - Friday, 31 January 2014, 13:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Exactly what is described here:
http://lists.gnu.org/archive/html/octave-bug-tracker/2014-01/msg00162.html

Since Octave 3.8.0 introduced a GUI, new packages are surely required in order for it to work properly, and some of them seem to have been forgotten when the code was compiled. The thread mentions that the symptoms can be cured by compling Octave with QScintilla support. The current problem is that "Show Editor" can be toggled, without any editor appearing.

Steps to reproduce:
Start Octave with the GUI: "octave --force-gui". Try to access the built-in editor through "Window", "Show Editor"/"Editor". Nothing happens.
This task depends upon

Closed by  Ronald van Haren (pressh)
Friday, 31 January 2014, 13:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  qscintilla is an optional dependency for octave 3.8.0-2
Comment by Philip Abernethy (Chais) - Thursday, 30 January 2014, 16:52 GMT
This can be fixed by adding qscintilla as a dependency. No other changes are necessary.
octave will automatically build against libqscintilla and properly enable the editor.
In the meantime I created AUR/octave-gui.
Comment by Martin Roth (Captain_Rage) - Thursday, 30 January 2014, 21:27 GMT
Good find! Yeah, installing package qscintilla does nothing as of yet.
Comment by Philip Abernethy (Chais) - Thursday, 30 January 2014, 21:42 GMT
Nope, it has to be built with it. It's required at build time and runtime for the editor to work.
Comment by Ronald van Haren (pressh) - Thursday, 30 January 2014, 22:00 GMT
I suppose the traditional non-gui stuff still works if qscintilla is added to makedepends and optdepends, but not installed at runtime?
Comment by Philip Abernethy (Chais) - Thursday, 30 January 2014, 22:03 GMT
Yes, but if octave was built against libqscintilla but it's not installed at runtime the gui won't start at all. So once it was built against libqscintilla qscintilla is mandatory for the gui.
Comment by Ronald van Haren (pressh) - Thursday, 30 January 2014, 22:06 GMT
Sure, that's intended. People have the choice if they want to use the GUI (with its dependencies) or not. Especially now that the GUI is still marked experimental by upstream I rather not force the extra dependencies on users. With optional dependencies we can keep everyone happy in this case.

[edit]
I'll push an update during the weekend.

Loading...