Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38657 - input not recognized randomly/system freezes

Attached to Project: Arch Linux
Opened by Matthias Krüger (matthiaskrgr) - Saturday, 25 January 2014, 11:17 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 07 February 2014, 00:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
For some reasons, clicks (I can still move the cursor for some reason and the location is updated on the screen) and keyboard input is not recongized/freezes in short time periods (2-3 minutes I'd guess). Sometimes I can work for longer periods though.
The freezes usually take around 3-5 seconds.

It seems to affect my entire desktop (thunar, xfce4-terminal, thunderbird, firefox awesomeWM etc..)
I haven't had this issue 2 days ago.


Additional info:

awesome 3.4.13-2
firefox 26.0-2
thunar 1.6.3-1
linux 3.12.8-1
xfce4-terminal 0.6.3-1


Steps to reproduce:
Use computer
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 07 February 2014, 00:26 GMT
Reason for closing:  Upstream
Comment by Matthias Krüger (matthiaskrgr) - Saturday, 25 January 2014, 11:31 GMT
When I put my system under heavy load, this seems to increase the chance for a freeze.
It seems like the desktop is frozen then (for exampe does not update while a freeze), but cursor is still rendered/updated.
Comment by Matthias Krüger (matthiaskrgr) - Saturday, 25 January 2014, 11:58 GMT
Seems that the system is actually not freezing, its just that nothing on the screen besides cursor is updated. When I switch workspaces in awesomeWM, I cant see that I switched workspace, but the cursor changes from text-mode (looking like a "I") to click mode.
Comment by Matthias Krüger (matthiaskrgr) - Saturday, 25 January 2014, 13:55 GMT
Seems to be a problem with my integrated chipset and the intel drivers.
Comment by Matthias Krüger (matthiaskrgr) - Saturday, 25 January 2014, 16:42 GMT
Apparently this was an upstream bug which will be fixed in the next release of xorg.
Comment by Tomasz Rybarczyk (paluh) - Monday, 27 January 2014, 19:11 GMT
I'm experiencing similar problems since last update (I did it 23.01.2014, but previous one was done around 13.01.2014).

I'm also running on intel integrated graphic chipset and in my Xorg.*.log I've found multiple stacktraces related to errors in graphic driver (/usr/lib/xorg/modules/drivers/intel_drv.so).

Have you found any similar bug report related to intel driver and this behavior?
Comment by Matthias Krüger (matthiaskrgr) - Monday, 27 January 2014, 19:18 GMT
No, but I found a temporary workaround via irc:

create a file "/etc/X11/xorg.conf.d/20-intel.conf "
containing this:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
# I should be able to remove this with xorg > 1.15.0
Option "AccelMethod" "blt"
EndSection
Comment by Tomasz Rybarczyk (paluh) - Monday, 27 January 2014, 21:33 GMT
After two hours of testing I can confirm that your workaround works! Thanks a lot!!!

Loading...