Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38595 - [p7zip] wxgtk dependency broken

Attached to Project: Arch Linux
Opened by PT. Ma. (BOYPT) - Tuesday, 21 January 2014, 06:23 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 21 January 2014, 09:06 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version 4.1.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

$ 7zG
/usr/lib/p7zip/7zG: error while loading shared libraries: libwx_gtk2u_core-2.8.so.0: cannot open shared object file: No such file or directory

$ pacman -Qo /usr/lib/p7zip/7zG
/usr/lib/p7zip/7zG is owned by p7zip 9.20.1-9

$ ldd /usr/lib/p7zip/7zG
linux-vdso.so.1 (0x00007fff8e5fe000)
libwx_gtk2u_core-2.8.so.0 => not found
libwx_baseu-2.8.so.0 => not found
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f3b6b063000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f3b6ae5f000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f3b6ab5b000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f3b6a945000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f3b6a59b000)
/lib64/ld-linux-x86-64.so.2 (0x00007f3b6b280000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f3b6a298000)

$ pacman -Qo /usr/lib/libwx_gtk2u_core-3.0.so
/usr/lib/libwx_gtk2u_core-3.0.so is owned by wxgtk 3.0.0-2
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 21 January 2014, 09:06 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Optional Deps : wxgtk2.8: GUI
Comment by PT. Ma. (BOYPT) - Tuesday, 21 January 2014, 06:26 GMT
installing wxgtk2.8 instead resolved.
p7zip should change the dependency.

Loading...