Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38567 - [netbeans] missing dependency "classpath"

Attached to Project: Community Packages
Opened by rick (xupwup) - Saturday, 18 January 2014, 19:39 GMT
Last edited by Alexander F. Rødseth (xyproto) - Saturday, 08 February 2014, 19:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Netbeans requires the dependency "classpath" to run, while this is not a dependency.


Additional info:
* package version(s)
netbeans 7.4-1

* config and/or log files etc.


Steps to reproduce:
- Create a new user (problem might be related to eula)
- install netbeans
- run netbeans
- observe
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Saturday, 08 February 2014, 19:44 GMT
Reason for closing:  Implemented
Comment by Alexander F. Rødseth (xyproto) - Thursday, 30 January 2014, 13:49 GMT
Hi, thanks for reporting. Adding classpath as a dependency. The updated package will appear in [community] shortly.
Comment by (Det) - Friday, 31 January 2014, 21:26 GMT
Hey there. This bug was reopened because there are some inconsistent results with other people successfully running NetBeans without Classpath.

Would you mind clarifying the installed JRE/JDK packages on your system and the _way_ you are running this thing? Classpath is a GNU implementation of the Java core class libraries and there should in my mind be no problems in running NetBeans without them.
Comment by rick (xupwup) - Saturday, 01 February 2014, 09:01 GMT
I believe it is related to the EULA which is shown on first run.
Comment by (Det) - Saturday, 01 February 2014, 11:30 GMT
Forgive me, I wasn't clear: the EULA is showing up with other people as well (it wouldn't make much sense to require classpath for it anyway).

Are you sure NetBeans doesn't start, if you uninstall classpath and then remove (or rename) ~/.netbeans/ and ~/.cache/netbeans/ to get the EULA? What is the error message?
Comment by rick (xupwup) - Saturday, 01 February 2014, 11:40 GMT
I can reproduce the error by uninstalling "atk", which was brought in as a dependency for classpath along with gtk2.

Classpath does not appear to be needed.
Comment by (Det) - Saturday, 01 February 2014, 11:52 GMT
All right then, but even without all of them the EULA still works just fine for me.

In fact, the only direct dependency of classpath that seems to be required is 'libxtst', which is already listed.
Comment by rick (xupwup) - Saturday, 01 February 2014, 15:51 GMT
classpath requires gtk2, which requires atk. Atk is required to run netbeans on my machine.
Comment by (Det) - Saturday, 01 February 2014, 19:34 GMT
That wasn't really helpful, but I think I've finally solved this. 'atk' is required for OpenJDK from the repos, while I tested it only with the Oracle JDK.

But then I don't know, if this is supposed to be a dependency for OpenJDK or for NetBeans. Either way, I'm glad it's sorted out.
Comment by Alexander F. Rødseth (xyproto) - Monday, 03 February 2014, 22:54 GMT
If classpath is needed for OpenJDK + Netbeans, but not for Oracle JDK + Netbeans, I'll keep it as a dependency.

OpenJDK requiring classpath would probably be a better solution, but then again, other applications that works for OpenJDK might not need it.

If I've understood the situation correctly, and have to choose between being OpenJDK-friendly or Oracle JDK-friendly, I choose OpenJDK.

Please re-open this bug if there should be further issues/problems/questions about this. (Or start a forum thread at https://bbs.archlinux.org/, re-open this bug and post the link).

Thanks for your help in investigating this.
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 05 February 2014, 15:45 GMT
Will change the dependency to only be atk, not classpath, since only atk is needed for OpenJDK + Netbeans, if I gather correctly.

Since Oracle JDK is only in AUR, and not an official package, Oracle JDK + Netbeans users will have to suffer the installation of atk without it really being needed.

About to update the package now.
Comment by (Det) - Wednesday, 05 February 2014, 15:49 GMT
I'm glad that's the conclusion you came into :).

Loading...