Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38506 - {bugtracker} Advanced Search returns blank page or http 500

Attached to Project: Arch Linux
Opened by Alexander Schnaidt (Namarrgon) - Tuesday, 14 January 2014, 14:53 GMT
Last edited by freswa (frederik) - Thursday, 20 February 2020, 21:08 GMT
Task Type Bug Report
Category Web Sites
Status Assigned
Assigned To Jelle van der Waa (jelly)
Sven-Hendrik Haase (Svenstaro)
Giancarlo Razzolini (grazzolini)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 4
Private No

Details

Description:
An 'Advanced Search' for 'Archlinux' projects with an empty search-field and 'Status' set to 'All Statuses' either results in a blank page or sometimes (under webserver load?) returns an HTTP 500.

Additional information:
- Searches related to other projects than 'Archlinux' return the expected information.
- The 'Miscellaneous' options semm to have no influence on that behavior.

Steps to reproduce:
1. open https://bugs.archlinux.org/
2. set Project to 'Arch Linux'
3. open the 'Advanced' options
4. set 'Status' to 'All Statuses'
5. leave search-field empty
6. hit the search-button
This task depends upon

Comment by Samantha McVey (samcv) - Thursday, 09 June 2016, 19:33 GMT
I can confirm that this bug still exists and I experienced the exact same result following "Steps to reproduce" above. Did not receive a 500 error in my few tests of this but did receive the blank page. Other projects did not have this issue.
Comment by Peter Liscovius (peterdd) - Tuesday, 18 February 2020, 09:22 GMT
Hi, peterdd from official Flyspray project here.

This is probably from high memory usage when a search finds many tasks of arch fork of Flyspray. Probably the arch web server then just kills the request with the error 500. A look at arch monitoring/logging should verify that.

I think I solved that issue several years ago in the official Flyspray sources. At least I have no problems with a 50k tasks/5k users test install on a cheap shared hosting with apache web server and php7.2

Cannot say much more because I do not know archs flyspray setup and configuration and they use nginx which official is not yet supported because nobody yet provided a nginx setup to Flyspray.
Comment by Giancarlo Razzolini (grazzolini) - Tuesday, 18 February 2020, 09:31 GMT
I'm bringing the Arch fork of flyspray in sync with the upstream fork later this week. Let's see if it fixes these issues. Also, btw, you can take a look at our nginx configuration here: https://git.archlinux.org/infrastructure.git/tree/roles/flyspray/templates/nginx.d.conf.j2

It took me a long time to figure this nginx configuration, but I think it covers everything.
Comment by Peter Liscovius (peterdd) - Sunday, 23 February 2020, 00:53 GMT
The probably related discussion started at https://bugs.flyspray.org/1673#comment4794 in 2015.

My today's test with 100k tasks and 30k users with current https://github.com/Flyspray/flyspray master branch works ok.

Probably similar problem is handling 30k users on the admin 'editallusers' page that has not yet a pagination or search/filter feature. Handling 2k users is ok with the 'basic' user fields select.
Comment by Peter Liscovius (peterdd) - Sunday, 23 February 2020, 01:59 GMT
@grazzolini just ask any question regarding Flyspray.

The current Flyspray 1.0-rcX sources assume Apache .htaccess working and is used to restrict direct access to some directories. So when you upgrade adapt your nginx configuration so.
For instance any direct access from outside to any file in the vendor/ directory should be prohibited.

Loading...