Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38478 - [virtualbox] Virtualbox prevents udev from loading usb_modeswitch rules

Attached to Project: Community Packages
Opened by Luca Monti (Mons1990) - Sunday, 12 January 2014, 09:55 GMT
Last edited by Sébastien Luttringer (seblu) - Wednesday, 19 March 2014, 21:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description.
Installed usb_modeswitch and it doesn't work. udev has his rules correctly configured to switch from ZeroCD Huawei E3131 but it doesn't, although it works if usb_modeswitch is called automatically from command line. More then one user reported that uninstalling VB it start to work and that usb_modeswitch started having problem since Virtualbox was updated.


Additional info:
Virtualbox 4.3.6-2 x86_64 (at least: I never tried with older versions or different architecture)
Other additional Info here:
https://bbs.archlinux.org/viewtopic.php?id=175443
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=1847
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Wednesday, 19 March 2014, 21:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox-4.3.8-2
Comment by Sébastien Luttringer (seblu) - Sunday, 12 January 2014, 11:17 GMT
Proably linked to the fix of https://bugs.archlinux.org/task/38314.

can you, reinstall virtualbox, remove /usr/lib/udev/rules.d/60-vboxdrv.rules, reboot your computer, and see if your usb device is correctly switched.
Comment by Luca Monti (Mons1990) - Sunday, 12 January 2014, 11:35 GMT
Followed these steps and it switched perfecly.
Comment by Aleksander Morgado (aleksander0m) - Friday, 24 January 2014, 18:52 GMT
The proposed solution seems to solve the issue, yes, I got by udev rules back... :)
Comment by Sergey Vlasov (sigprof) - Friday, 28 February 2014, 04:55 GMT
/lib/udev/rules.d/60-vboxdrv.rules included in the package is broken — it uses RUN="command...", which overwrites all RUN commands set in earlier rules. This breaks not only usb_modeswitch, but also some other packages which add RUN commands for USB devices.

See the upstream script which generates 60-vboxdrv.rules when using the official VirtualBox installer:

https://www.virtualbox.org/browser/vbox/trunk/src/VBox/Installer/linux/installer-common.sh

Note the usage of RUN+="command..." — this adds a command to the existing list instead of overwriting the whole list, and replacing RUN="..." with RUN+="..." makes usb_modeswitch work together with VirtualBox.
Comment by Sébastien Luttringer (seblu) - Sunday, 02 March 2014, 13:01 GMT
Thanks for troubleshooting Sergey. I will push a new version in few days.
Comment by Sébastien Luttringer (seblu) - Tuesday, 18 March 2014, 01:30 GMT
Fixed version is in testing, could you confirm?

Loading...