Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38463 - [graphicsmagick, octave] graphicsmagick-1.3.19-2 breaks imread() in octave

Attached to Project: Arch Linux
Opened by Ian Sage (ian11213) - Saturday, 11 January 2014, 15:55 GMT
Last edited by Gaetan Bisson (vesath) - Saturday, 11 January 2014, 17:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Gaetan Bisson (vesath)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Latest package upgrade took graphicsmagick from 1.3.18-6 to 1.3.19-2
After this upgrade, attempts to use imread function in Octave, give error:

octave:1> a=imread("foo.jpg");
error: imread: invalid image file: Magick++ exception: Magick: No decode delegate for this image format () reported by magick/constitute.c:1522 (ReadImage)
error: called from:
error: /usr/share/octave/3.6.4/m/image/imread.m at line 74, column 7

Downgrading the package back to 1.3.18-6 restores normal operation.

Additional info:
Octave version is 3.6.4-5

Steps to reproduce:
Same error occurs in new install of Arch on a separate machine
Same error when attempting to imread .png, .bmp
This task depends upon

Closed by  Gaetan Bisson (vesath)
Saturday, 11 January 2014, 17:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  octave-3.6.4-6 in [extra]
Comment by Gaetan Bisson (vesath) - Saturday, 11 January 2014, 16:35 GMT
How about graphicsmagick-1.3.19-1?

Loading...