Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38460 - [easytag] stack smashing crash

Attached to Project: Arch Linux
Opened by c (c) - Saturday, 11 January 2014, 14:10 GMT
Last edited by Guillaume ALAUX (galaux) - Tuesday, 28 January 2014, 17:07 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Guillaume ALAUX (galaux)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
easytag 2.1.9 crashes randomly by selecting folder in the gui and
doesn't display right icons as it used to in 2.1.8. If it doesn't
crash you can see many icons replaced with placeholder icons.

*** stack smashing detected ***: easytag terminated
======= Backtrace: =========
/usr/lib/libc.so.6(+0x6d9a1)[0xb6b869a1]
/usr/lib/libc.so.6(__fortify_fail+0x45)[0xb6c16465]
/usr/lib/libc.so.6(+0xfd41a)[0xb6c1641a]
/usr/lib/libid3-3.8.so.3(_fini+0x0)[0xb6ddd2d4]
/usr/lib/libid3-3.8.so.3(_ZN7Mp3Info5ParseER10ID3_Readerj+0x860)[0xb6dd0b40]
/usr/lib/libid3-3.8.so.3(_ZN11ID3_TagImpl11ParseReaderER10ID3_Reader+0x3c6)[0xb6dd5b26]
/usr/lib/libid3-3.8.so.3(_ZN11ID3_TagImpl9ParseFileEv+0x17d)[0xb6dd619d]
/usr/lib/libid3-3.8.so.3(_ZN11ID3_TagImpl4LinkEPKct+0x4e)[0xb6dd1ebe]
/usr/lib/libid3-3.8.so.3(_ZN7ID3_Tag4LinkEPKct+0x2f)[0xb6dd11af]
/usr/lib/libid3-3.8.so.3(ID3Tag_LinkWithFlags+0x34)[0xb6dc2ea4]
easytag[0x8098392]


Additional info:
* 2.1.9


Steps to reproduce:
Start easytag and select a folder with audio files.
This task depends upon

Closed by  Guillaume ALAUX (galaux)
Tuesday, 28 January 2014, 17:07 GMT
Reason for closing:  Upstream
Comment by c (c) - Sunday, 26 January 2014, 08:50 GMT
News?
Comment by Guillaume ALAUX (galaux) - Sunday, 26 January 2014, 10:41 GMT
I cannot reproduce this. I can start EasyTag and select a folder with 8000 audio files and 800 subfolders with no crash.

local/easytag 2.1.9-1
local/glibc 2.18-12 (base)
local/id3lib 3.8.3-13

Can you isolate a file or a way to reproduce this?
Comment by Guillaume ALAUX (galaux) - Sunday, 26 January 2014, 14:26 GMT
> Hi,
> attached mp3 track smashes kid3-qt and easytag.
> …

EasyTag and kid3-qt both work fine here on an audio file I was privately sent for test/debugging purpose and that was said to make them crash.

If multiple tagging applications fail, I would say the issue could come from id3lib.

As said previously, I have tested it with id3lib 3.8.3-13 and glibc 2.18-12 (latest versions available when I speak). Could you please check these are the versions you are using?
Comment by Guillaume ALAUX (galaux) - Sunday, 26 January 2014, 14:37 GMT
FYI audio file can be found here  FS#38670 
Comment by rob.til.freedman (rtfreedman) - Sunday, 26 January 2014, 15:20 GMT
>I have tested it with id3lib 3.8.3-13 and glibc 2.18-12
Same here. I assume you tried it on i686, did you?
Comment by Guillaume ALAUX (galaux) - Sunday, 26 January 2014, 15:41 GMT
No, I have no i686 machine. I noticed this on the bug report.
Does 'id3info' crashes to?
$ id3info 01\ -\ track01.mp3
Comment by rob.til.freedman (rtfreedman) - Sunday, 26 January 2014, 20:20 GMT
> Does 'id3info' crashes to?
Yes. Looks like a parsing error in libid3.
Comment by Guillaume ALAUX (galaux) - Sunday, 26 January 2014, 20:40 GMT
Nice. Would you mind opening a bug report to the upstream project then?

http://id3lib.sourceforge.net/
Comment by rob.til.freedman (rtfreedman) - Sunday, 26 January 2014, 21:28 GMT
http://sourceforge.net/p/id3lib/mailman/id3lib-devel/
Re: [id3lib-devel] patch for c99 bool
From: Cedric Tefft <shadrack@us...> - 2013-02-22 08:40:50

id3lib is effectively unmaintained at this point.

Haven't used gdb for a long time ;)
Comment by test0 (test0) - Monday, 27 January 2014, 06:25 GMT Comment by rob.til.freedman (rtfreedman) - Monday, 27 January 2014, 19:02 GMT
@test0
Thanks for the pointer - build with most of the patches fixes my problem.
Comment by Guillaume ALAUX (galaux) - Monday, 27 January 2014, 22:38 GMT
Can you identify which patche(s) fixe(s) it?
Comment by rob.til.freedman (rtfreedman) - Monday, 27 January 2014, 23:02 GMT
>Can you identify which patche(s) fixe(s) it?
61-fix_vbr_stack_smash.patch

I've opened a bug here: https://bugs.archlinux.org/task/38691
Comment by Guillaume ALAUX (galaux) - Tuesday, 28 January 2014, 17:05 GMT
Nice thanks. I'm closing this bug report and assigning  FS#38691  to myself as id3lib is currently an orphan.

Loading...