Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38447 - [grub] 2.02 kernel panic with one of the entries

Attached to Project: Arch Linux
Opened by Charles Bos (Chazza) - Friday, 10 January 2014, 21:56 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 08 April 2014, 06:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
The problem is that one of the menu entries generated with grub 2.02 gives me a kernel panic. This is my setup:

Windows 7 on /dev/sda1 and /dev/sda2
Arch linux root partition on /dev/sda3 with both the linux and linux-lts kernels.
Swap and home partitions contained in an extended partition.

When I run grub-mkconfig -o /boot/grub/grub.cfg it produces a standard entry and a fallback entry for both the linux and linux-lts kernels as well as a Windows entry. These entries all work fine. But it also produces a couple of new menu entries: "Arch Linux" and "Advanced options for Arch Linux." The plain "Arch Linux" entry attempts to boot the lts kernel at which point there is a kernel panic.

Additional info:
* package version(s)
grub 1:2.02.beta2-1
linux 3.12.6-1
linux-lts 3.10.25-1
os-prober 1.58-1

* config and/or log files etc.

Steps to reproduce:
Attempt to boot the "Arch Linux" menu entry in grub 2.02
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 08 April 2014, 06:27 GMT
Reason for closing:  Fixed
Comment by John (graysky) - Friday, 10 January 2014, 23:36 GMT
I can confirm this behavior without the Windows 7 partition. Glad to post my grub.cfg that the new version generated upon request. Downgrading and regenerating the cfg file fixes.
Comment by Tobias Powalowski (tpowa) - Saturday, 11 January 2014, 07:08 GMT
Should be fixed in 2.02-beta2, please confirm.
Comment by John (graysky) - Saturday, 11 January 2014, 12:52 GMT
If I look at the PKGBUILD in trunk it is the same as what is in [core] so I am confused by your statement, tpowa.

core/grub 1:2.02.beta2-1
trunk/grub 1:2.02.beta2-1

For me, it is 1:2.02.beta2-1 that causes the kernel panic with one entry and the following for the default boot entry:

"ERROR: Boot device mounted suffesscully but /sbin/init does not exist.
Bailling out, you are on your own. Good luck.

sh: can't access tty: job control turned off
[rootfs /]#"

I have attached two grub.cfg files generated by grub-mkconfig named for their respective versions. I hope these help you troubleshoot... they don't look as though the problem originates therein to me. This might be an upstream bug.
Comment by Charles Bos (Chazza) - Saturday, 11 January 2014, 13:06 GMT
Here is my grub.cfg for grub 1:2.02.beta2-1
As graysky says it IS beta2 that generates the menu that causes the kernel panic.
   grub.cfg (8.6 KiB)
Comment by Charles Bos (Chazza) - Saturday, 11 January 2014, 17:03 GMT
Removing the linux-lts kernel and regenerating the menu fixes the "Arch Linux" entry. It will boot without a kernel panic. I can only conclude that the problem lies with having the linux and linux-lts kernels installed on the same machine. I've included the regenerated grub.cfg
   grub.cfg (6.4 KiB)
Comment by Keshav Amburay (the.ridikulus.rat) - Saturday, 11 January 2014, 18:29 GMT
Use the entries marked as "Arch Linux pkg-linux* kernel" in the menuentry title. These entries are generated by 10_archlinux and detects the main and fallback initramfs files properly. The entries you are talking about are created by upstream provided 10_linux script which detects Arch kernels but not the initramfs files and thus the generated menuentries do not have the "initrd" lines and while booting cause kernel panic.
Comment by John (graysky) - Saturday, 11 January 2014, 20:18 GMT
@rat - When I boot from the first entry or 2nd entry, I get the error regarding /sbin/init. When I boot from the 3rd entry, I get the panic.
Comment by Charles Bos (Chazza) - Saturday, 11 January 2014, 23:20 GMT
@rat you are correct. the pkg-linux entries work just fine. it was only the "Arch Linux" entry that was giving me the kernel panic.

@graysky I am not familiar with the problems you are describing. I have not encountered any /sbin/init errors. perhaps yours is a seperate issue?
Comment by Charles Bos (Chazza) - Sunday, 12 January 2014, 15:10 GMT
I made the 10_linux script in /etc/grub.d non executable and then regenerated the grub menu and the broken menu entries disappeared! For me the problem is solved. Thanks guys.
Comment by Joshua Brown (browntown) - Tuesday, 14 January 2014, 16:04 GMT
should be merger with 38455? Seems like the same problem, duplication of the 10_linux script. There's a thread going in [testing] about the issue.
Comment by John (graysky) - Saturday, 18 January 2014, 17:40 GMT
I opened 38566 describing the issue I commented on here - sorry to have taken this particular ticket off topic.
Comment by Tobias Powalowski (tpowa) - Tuesday, 25 February 2014, 11:35 GMT
Please try 2.02.beta2-2 package from testing repository.
Comment by Tobias Powalowski (tpowa) - Monday, 07 April 2014, 14:58 GMT
Please try latest grub from testing.
Comment by Charles Bos (Chazza) - Monday, 07 April 2014, 19:29 GMT
Tried the latest grub from testing and I can confirm that it fixes the problem. grub-mkconfig generates working menu entries without needing to disable any of the scripts in /etc/grub.d

There is one very minor issue I should mention though. In the Advanced options for Arch Linux menu the entries are named something like 'Arch Linux with linux linux'

The entry boots just fine but the naming is a little odd.

Loading...