Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38426 - Xorg failure because of libgcrypt update

Attached to Project: Arch Linux
Opened by Chuck (foxcm2000) - Thursday, 09 January 2014, 01:07 GMT
Last edited by Allan McRae (Allan) - Thursday, 09 January 2014, 01:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I'm stuck running X server 1.14 because of this bug: https://bugs.archlinux.org/task/38308

Everything was working fine by holding back from upgrading to xorg server 1.15 UNTIL today when libgcrypt got upgraded and broke Xorg server (/usr/bin/X: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory)

The upgraded libgcrypt is incompatible with Xorg server 1.14

Suggestion: Mask off libgcrypt for those of use stuck with Xorg server 1.14 so that libgcrypt won't upgrade and cause breakage.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 09 January 2014, 01:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial upgrades are not supported.
Comment by Chuck (foxcm2000) - Thursday, 09 January 2014, 01:10 GMT
OH LOVELY! I just downgraded manually and realized that systemd now *requires* libgcrypt2. For a library like this that could very well be used by multiple programs that need different versions, could we please have the ability to install both versions in tandem?

Loading...