Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38416 - [x2go-server] Can't locate Config/Simple.pm

Attached to Project: Arch Linux
Opened by Maciej Sitarz (macieks2) - Wednesday, 08 January 2014, 09:20 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 08 January 2014, 19:38 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
During upgrade process yaourt showed me that the perl-config-simple package is no longer a dependency and I can remove it.
After that upgrade of x2goserver (to version 4.0.1.11-1, later one more update to 4.0.1.12-1) x2go-client started to show error message about missing perl module (error msg below).

Additional info:
* package versions:
x2goserver 4.0.1.12-1 or 4.0.1.11-1
* error message shown by x2go-client:
Connection failed Can't locate Config/Simple.pm in @INC (you may need to install the Config::Simple module) (@INC contains: /usr/lib/x2go /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/lib/x2go/x2godbwrapper.pm line 24. BEGIN failed--compilation aborted at /usr/lib/x2go/x2godbwrapper.pm line 24. Compilation failed in require at /usr/bin/x2golistsessions line 30. BEGIN failed--compilation aborted at /usr/bin/x2golistsessions line 30.

Steps to reproduce:
1. Have x2goserver installed
2. Uninstall perl-config-simple
3. Try to connect to the server

Workaround:
Have perl-config-simple installed, even package dependencies doesn't require it.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 08 January 2014, 19:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.0.1.12-2

Loading...