Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38337 - [mplayer]-36498-4 is compiled with newlibgcrypt not available in core yet (exists in testin

Attached to Project: Arch Linux
Opened by balwierz (balwierz) - Wednesday, 01 January 2014, 13:35 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 01 January 2014, 18:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

mplayer package from „extra” depends on libgcrypt:
$ ldd /usr/bin/mplayer
libgcrypt.so.20 => not found

which is not available in „core”, but exists in „testing”.
Moreover the dependency on libgcrypt is not stated in the package info at all (any version),.

$ sudo pacman -Qi mplayer
Name : mplayer
Version : 36498-4

$ sudo pacman -Qi libgcrypt
Name : libgcrypt
Version : 1.5.3-1

$ sudo pacman -Qo /usr/lib/libgcrypt.so*
/usr/lib/libgcrypt.so is owned by libgcrypt 1.5.3-1
/usr/lib/libgcrypt.so.11 is owned by libgcrypt 1.5.3-1
/usr/lib/libgcrypt.so.11.8.2 is owned by libgcrypt 1.5.3-1

Updating to libgcrypt-1.6 form „testing” would fix the problem with mplayer, but would cause more problems with other packages not compiled against the new libgcrypt.

This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 01 January 2014, 18:13 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Wednesday, 01 January 2014, 14:48 GMT
mplayer does not link libgcrypt. Use "readelf -d /usr/bin/mplayer" to see. It must be a dependency that does.
Comment by Allan McRae (Allan) - Wednesday, 01 January 2014, 14:59 GMT
In fact, I can not replicate at all...

$ldd /usr/bin/mplayer | grep libgcr
libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0x00007ff8b02c2000)
Comment by Evangelos Foutras (foutrelis) - Wednesday, 01 January 2014, 15:47 GMT
mplayer doesn't directly link to libgcrypt; the dependency chain goes something like this:

mplayer -> libsmbclient.so.0 -> libgse.so -> libauthkrb5.so -> libgcrypt.so.11

So it seems that you have installed smbclient 4.1.3-2 from [testing] which is compiled against the new libgcrypt.

If that is the case, you'll need to fully update your system (https://wiki.archlinux.org/index.php/pacman#Partial_upgrades_are_unsupported).
Comment by balwierz (balwierz) - Wednesday, 01 January 2014, 16:41 GMT
Thanks fourtrelis. This was the case. Downgrading solved the issue.
Please close and change to NOTABUG.
If anything, somewhere in the dependency chain should have appeared a conflict to prevent such installs.
I installed smbclient from testing without --force option and received no errors from pacman.


Loading...