Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38329 - [ardour] version is incorrect

Attached to Project: Arch Linux
Opened by Uli (Army) - Tuesday, 31 December 2013, 09:48 GMT
Last edited by Ray Rashif (schivmeister) - Tuesday, 25 February 2014, 19:43 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After the recent update

[2013-12-28 22:51] [PACMAN] upgraded ardour (3.5.74-1 -> 3.5.143-1)

ardour always shows on startup, that the new version 3.5.143 is released. Me wondering, why this message pops up, I was looking up its real version.

$ ardour3 -v
bnd txt domain [gtk2_ardour3] to /usr/share/locale
Ardour3.5.142 (built using 3.5-142-g9f17579 and GCC version 4.8.2 20131219 (prerelease))

So this package isn't up to date!
This task depends upon

Closed by  Ray Rashif (schivmeister)
Tuesday, 25 February 2014, 19:43 GMT
Reason for closing:  Fixed
Comment by Mauro Frischherz (fmauro) - Wednesday, 22 January 2014, 10:32 GMT
Not so much outdated as incorrectly labeled.
Comment by Uli (Army) - Wednesday, 22 January 2014, 10:37 GMT
You are right, it's not much outdated. That's why I chose severity=low. But it IT outdated ;)
Comment by Mauro Frischherz (fmauro) - Wednesday, 22 January 2014, 10:56 GMT
Yeah but you should not report a bug for an outdated package.
I would love the correct version easily accessible as well, there are some nice fixes there.
Comment by Uli (Army) - Wednesday, 22 January 2014, 11:18 GMT
I know that the bugtracker is not for reporting outdated packages. It's not what I intended when I filed this bug report. It's just that the version pacman shows isn't the version of the software. This I consider a bug.

I just tried to build ardour from the github mirror, because it provides a tagged snapshot of the current release. But the build process failed with an error message, because a file was missing...
Comment by Ray Rashif (schivmeister) - Wednesday, 22 January 2014, 17:00 GMT
You are correct that this is a bug, and a very strange one. Either I f'ed up the tarball (I never unpack releases in place), or upstream released a tarball that they shouldn't have (which has happened before). Thanks for the report, I'll attend to it shortly.
Comment by Ray Rashif (schivmeister) - Sunday, 26 January 2014, 09:27 GMT
Turns out that this can be considered to not be a bug. Judging from the code, they do not update the revision information when making a source release (they do it only for their binaries, I suppose). We can either hack it away or live with it. Still waiting for a response from the developers on IRC.
Comment by Uli (Army) - Sunday, 26 January 2014, 13:12 GMT
Hm, ok, I'd say let's live with it. The only annoyance is this update-available-message which appears when I launch Ardour and keeps resizing the window. But I can absolutely live with it!
Comment by Ray Rashif (schivmeister) - Thursday, 30 January 2014, 18:43 GMT
  • Field changed: Category (Packages: Extra → Upstream Bugs)
I'm keeping this open, as it seems a little strange why simply sed'ing the revision number causes the build system to break down.
Comment by Uli (Army) - Sunday, 02 February 2014, 17:41 GMT
You probably noticed this yourself, but now after the update I get this

$ pacman -Qi ardour | grep Version
Version : 3.5.308-1

$ ardour3 -v
bnd txt domain [gtk2_ardour3] to /usr/share/locale
Ardour3.5.284 (built using 3.5-284-g8b71e40 and GCC version 4.8.2 20131219 (prerelease))

And launching ardour it tells me "Version 3.5.308 has been released. Update at http://ardour.org/download";

So again the versions don't match.

Maybe it's better to build the package from git?
Comment by Ray Rashif (schivmeister) - Sunday, 02 February 2014, 18:02 GMT
Like I said and explained in my previous comments, this is upstream. If users want a git-based build, I have no problem. I will have to check out their tagged release and see if the same issue exists (in which case it'd be pointless to move to it).
Comment by Ray Rashif (schivmeister) - Monday, 17 February 2014, 06:57 GMT
The bug is beginning to bite me (OOD flags). If there are no objections to a git-based package, and no response from upstream after a second attempt at communication, I'll push a reworked package.
Comment by Uli (Army) - Monday, 17 February 2014, 07:54 GMT
+1 for git
Comment by Ray Rashif (schivmeister) - Tuesday, 25 February 2014, 08:34 GMT
The latest release fixed itself. I still want to talk about the possibility of a git-based package.

In particular, users will lose direct upstream support by using a git-based build. [1] There are significant differences between a release tarball and a git tagged checkout; there is no version information in the latter. See the list of file differences. [2]

So, what you get is a little different than what upstream wants its end-users to get. However, if we define ourselves as anything but end-users, then I see absolutely no problem using a git checkout.

[1] http://community.ardour.org/s/source
[2] http://bpaste.net/show/182571/
Comment by Uli (Army) - Tuesday, 25 February 2014, 08:39 GMT
Isn't this something you could (or should) discuss on arch-dev-public? If this problem now is gone for good in the releases, I'd stick with them. Did you get to talk to Paul (ardour dev) about it?
Comment by Ray Rashif (schivmeister) - Tuesday, 25 February 2014, 17:18 GMT
It was discussed some time ago privately on IRC, and it never went to -public because nobody could care less. Paul doesn't even like the idea of distributions and would prefer that you went to his site and got the binary for a little donation.

Anyway, it was decided that we could shift to a git-tagged package if and when trouble arises (mostly from upstream being angry about storing their source). This just became the first trouble.

The next trouble would probably make me announce the shift and possible exclusion of users from upstream support. Thanks for your input, closing.

Loading...