Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38240 - [libva-intel-driver] Mixed up colors in gnome-mplayer with VA-API support

Attached to Project: Arch Linux
Opened by Mark E. Lee (bluerider) - Monday, 23 December 2013, 02:02 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Saturday, 04 January 2014, 08:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
On a recent upgrade of libva-intel-driver (1.2.1-1 -> 1.2.2-1); I found the colors on x264 videos to be mixed up. Attached is a screenshot illustrating the issue.

Additional info:
gnome-mplayer 1.0.8-1
libva-intel-driver 1.2.2-1


Steps to reproduce:
Try to playback a x264 video (mine was in a .mp4 container) with gnome-mplayer using vaapi acceleration.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Saturday, 04 January 2014, 08:08 GMT
Reason for closing:  Fixed
Comment by Balló György (City-busz) - Monday, 23 December 2013, 07:31 GMT
I confirm this bug. Please report it to the upstream developers:
https://code.google.com/p/gnome-mplayer/source/list
Comment by Mark E. Lee (bluerider) - Tuesday, 24 December 2013, 15:54 GMT Comment by Mark E. Lee (bluerider) - Monday, 30 December 2013, 04:54 GMT
Haihao has seemingly fixed the issue. I have tested it on both ironlake and sandybridge hardware. I'll attach an updated PKGBUILD and his patch until he upstreams the fixes.
Comment by Mark E. Lee (bluerider) - Saturday, 04 January 2014, 04:36 GMT
Is there any progress to this? We already have the patch; can't we just apply it to libva-intel-driver and release it as 1.2.2-2 since there's no 1.2.3 yet?

Loading...