Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38222 - [grub] grub-mkconfig produce entries for every architecture

Attached to Project: Arch Linux
Opened by Tom Yan (tom.ty89) - Saturday, 21 December 2013, 22:38 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Thursday, 01 May 2014, 19:38 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
# grub-mkconfig -o /boot/grub/grub.cfg
   grub.cfg (20.5 KiB)
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Thursday, 01 May 2014, 19:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  grub-1:2.02.beta2-3
Comment by wtf (oi_wtf) - Saturday, 21 December 2013, 22:50 GMT
I noticed that, too.
It's clearly not necessary,
I mean, how often is the architecture of your cpu changing?!?
On top of that, I couldn't see any difference in those entries.
Comment by Peter Wu (Lekensteyn) - Sunday, 22 December 2013, 22:32 GMT
Workaround, removing all pkg-linux* kernel entries:

chmod a-x /etc/grub.d/10_archlinux

There is still a x86_64-xen entry I cannot get rid of (even after `chmod a-x 20_linux_xen`) though, but at least I do not have over 40 entries (not kidding, there are three custom kernels here for testing purposes plus the stock kernel).
Comment by Tom Yan (tom.ty89) - Monday, 23 December 2013, 06:31 GMT
I also found that removing 10_archlinux can reduce the number of entries to two (x86 and x86_64-xen), while I am with an Arch 64
When I look into grub-mkconfig, "x86_64" is not in the iteration.

Though I do notice that when in actual boot, only one entry would be shown. The "testing mechanism" did work.

P.S. Is Arch not going to adopt the submenu thing? Sounds good if the fallback mode can be made an "advance option", if it can be done so.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 24 December 2013, 07:06 GMT
This has nothing to do with the code in 10_archlinux . It is due to some upstream grub-mkconfig changes. See http://lists.gnu.org/archive/html/grub-devel/2013-12/msg00346.html for the related discussion. This change may be reverted by upstream before 2.02 stable release.

EDIT 1: You guys can try modified 10_archlinux I uploaded to grub-git AUR pkg maintained by me.

EDIT 2: Personally I suggest everyone to manually maintain their grub.cfg file. It is simply a scaled down shell script. See https://wiki.archlinux.org/index.php/UEFI#Using_GRUB and my grub.cfg (attached) for examples. Most of the perceived complexity of GRUB comes from the grub-mkconfig generated grub.cfg . Arch does not auto overwrite /boot/grub/grub.cfg file unlike other distros, so it is safe to manually maintain grub.cfg . Syslinux does not come with any built-in config generator (neither upstream nor any Arch specific script/tool) and that works perfectly well for users. I don't think that should not work for GRUB.

EDIT 3: Although I submitted the 10_archlinux script and checked the generated grub.cfg (separate /boot, so didn't catch the ${subdir} vs ${SUBDIR} issue discussed at https://bugs.archlinux.org/task/38223), I use my manually written grub.cfg since GRUB 2.00-beta1 release and it works perfectly well for me.
   grub.cfg (8.1 KiB)
Comment by Philip Müller (philm) - Wednesday, 25 December 2013, 10:27 GMT
It is already fixed by upstream and included in 2.02-beta2. See: http://git.savannah.gnu.org/cgit/grub.git/commit/?id=faf4a65e1e1ce1d822d251c1e4b53d96ec7faec5
Comment by Keshav Amburay (the.ridikulus.rat) - Sunday, 05 January 2014, 08:35 GMT
Updated 10_archlinux to work with grub 2.02-beta2 attached.
Comment by Tobias Powalowski (tpowa) - Saturday, 11 January 2014, 07:05 GMT
Should be fixed in 2.02-beta2, please confirm.
Comment by Peter Wu (Lekensteyn) - Saturday, 11 January 2014, 11:36 GMT
Fix confirmed for 1:2.02.beta2-1.
Comment by Alfred Krohmer (devkid) - Saturday, 08 February 2014, 18:21 GMT
  • Field changed: Percent Complete (100% → 0%)
Still happening on grub 1:2.02.beta2-1 today on a fresh Arch install.
Comment by Tobias Powalowski (tpowa) - Tuesday, 25 February 2014, 11:35 GMT
Please try 2.02.beta2-2 package from testing repository.
Comment by Alfred Krohmer (devkid) - Thursday, 27 February 2014, 16:04 GMT
Still happening with 2.02.beta2-2

I get two normal entries from 10_archlinux (normal boot and fallback) and another two from 10_linux: "Arch Linux" and a submenu "Advanced options for Arch Linux" with "Arch Linux, with Linux linux".
Comment by wtf (oi_wtf) - Thursday, 27 February 2014, 16:29 GMT
do either
# chmod -x /etc/grub.d/10_linux
or
# chmod -x /etc/grub.d/10_archlinux
Comment by Tobias Powalowski (tpowa) - Monday, 07 April 2014, 14:56 GMT
Please try latest grub from testing.

Loading...