Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38196 - grub-mkconfig generates invalid file

Attached to Project: Arch Linux
Opened by David Kreuter (dkreuter) - Thursday, 19 December 2013, 21:33 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 19 December 2013, 21:49 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For me grub-mkconfig (more specifically /etc/grub.d/10_linux) generates a file with
submenu 'Advanced options for Arch Linux' $menuentry_id_option '...' {
but no corresponding
}

As far as I can see this is caused by the patch https://projects.archlinux.org/svntogit/packages.git/tree/trunk/archlinux_grub_mkconfig_fixes.patch?h=packages/grub&id=d501fa5bb23263153389f199f655894467f1c104 which (at the very bottom) makes the emission of the '}' conditional with
if ! test -e "/etc/arch-release" ; then

I believe this is a bug.

My version of grub (according to pacman -Qi) is 1:2.00.1282.g5ae5c54-1.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 19 December 2013, 21:49 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#37904 
Comment by David Kreuter (dkreuter) - Thursday, 19 December 2013, 21:41 GMT
I just noticed that this is a duplicate of #37904 -.-

Loading...