Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3818 - MySQL 5.0.18 doesn't accept TCP connections

Attached to Project: Arch Linux
Opened by Marc St-Laurent (peart) - Sunday, 22 January 2006, 16:42 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To No-one
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Attempts to connect to MySQL 5.0.18 using TCP always give this error: "ERROR 2013 (HY000): Lost connection to MySQL server during query". Connections worked with the previous package, version 5.0.17. The config has remained unchanged. Only TCP connections are affected. Connections using Unix sockets worked before, and still work now.

2 ways to duplicate this error:
1) mysql --user=user --password=pswd --protocol=TCP --host=A.B.C.D --port=3306 db_name
2) Try to access MySQL with JDBC. TCP is required for JDBC connections, Unix sockets aren't supported.

See forum thread http://bbs.archlinux.org/viewtopic.php?t=18096
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Monday, 23 January 2006, 17:28 GMT
Reason for closing:  Not a bug
Comment by Jürgen Hötzel (juergen) - Sunday, 22 January 2006, 21:33 GMT
5.0.18-1 enabled tcpwrappers. You have

mysqld: YOUR_NETWORK

in your /etc/hosts.allow?

Jürgen
Comment by Marc St-Laurent (peart) - Monday, 23 January 2006, 15:26 GMT
Yep, that fixes it. Thanks for your help.

Loading...