Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38170 - [cheese] Permission issues after update

Attached to Project: Arch Linux
Opened by Martin Roth (Captain_Rage) - Tuesday, 17 December 2013, 00:30 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 05 July 2015, 15:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Cheese was working fine, then it stopped working after the gstreamer / gst-plugins-* packages were upgraded (it would seem). It starts as intended, and the webcam captures a picture and shows it on the screen, but when trying to record a video or take a photo it says "There was an error playing a video from the webcam." and the picture disappears. When running from a terminal this appears:

"[martin@Wisp ~]$ cheese

(cheese:811): GLib-GObject-WARNING **: value "5.000000" of type 'gdouble' is invalid or out of range for property 'delaytime' of type 'gdouble'

(cheese:811): cheese-WARNING **: Error while writing to file "/2013-12-17-012604.jpg".: gstmultifilesink.c(653): gst_multi_file_sink_render (): /GstCameraBin:camerabin/GstMultiFileSink:imagebin-filesink:
Permission denied"

The webcam is working fine in Skype / VLC, both for running and for writing files (in VLC it is no problem to write a file).
Adding the users to the 'video' group made no difference.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 05 July 2015, 15:31 GMT
Reason for closing:  No response
Comment by Jan de Groot (JGC) - Tuesday, 17 December 2013, 06:29 GMT
Looks like you're trying to record to /. Probably something is wrong in your preferences.

The gstreamer 0.10 should have no impact on cheese, as that uses 1.0+.
Comment by Martin Roth (Captain_Rage) - Tuesday, 17 December 2013, 09:06 GMT
Thank you very, very much, this was actually the problem. Preferences cannot be set in Cheese, however, you have to fire up dconf Editor and change the 'video-path' and 'photo-path' directories. For some reason both were blank, which I doubt should be the case, so I would still say a bug is still around.

For 'photo-path' it says:
'Description: Defines the path where the videos are stored. If empty, "XDG_PHOTO/Webcam" will be used.'
'Type: String'
'Default: "'

For 'video-path' it says:
'Description: Defines the path where the videos are stored. If empty, "XDG_VIDEO/Webcam" will be used.'
'Type: String'
'Default: "'

When the 'Set to Default' button is pressed, both are blanked out again. This is obviously wrong. I don't know what is causing these strange default values.
By setting the directories manually I got it working, so thanks again!
Comment by Jan de Groot (JGC) - Tuesday, 17 December 2013, 23:23 GMT
They're supposed to be blank, when they're blank cheese will store these in G_USER_DIRECTORY_VIDEOS/Webcam or G_USER_DIRECTORY_PICTURES/Webcam. Why g_get_user_special_dir (G_USER_DIRECTORY_VIDEOS) returns nothing (or /) in your case is unknown to me.
Comment by Luck Darnière (LuX) - Friday, 27 December 2013, 13:41 GMT
Same problem for me (cheese first installed today).

Variables [XDG|G_USER_DIRECTORY]_[PHOTO|PICTURES] are empty for me. Is it because I am not using the gnome Desktop? I'm using openbox and xfce, and have this problem with cheese in both environments. Setting these variables by hand ("export XDG...") did not change anything: cheese still tries to save pictures and videos in the root directory.

Setting the values of 'photo-path' and 'video-path' to a directory 'cheese' in my $HOME as Martin Roth said (thanks for that) did not completely solve the problem either: photos and videos are stored in the expected directory, but cheese hangs on after I take a picture (even the window cannot be moved). I also get new error messages:

(cheese:10216): GnomeDesktop-WARNING **: Unable to create loader for mime type video/webm: Unrecognized image file format

(cheese:10216): GnomeDesktop-WARNING **: Error creating thumbnail for file:///users/tux/cheese/2013-12-27-142343.webm: Unrecognized image file format

** (cheese:10216): WARNING **: could not generate thumbnail for /users/tux/cheese/2013-12-27-142343.webm (video/webm)

Comment by Martin Roth (Captain_Rage) - Saturday, 28 December 2013, 02:23 GMT
Same here. Worth mentioning that I run Compiz standalone as desktop environment. When starting the program and trying to record a video or take a photo it gives an error! I have to switch between the the video/photo mode first, otherwise nothing will work.
Comment by rob.til.freedman (rtfreedman) - Saturday, 25 January 2014, 22:39 GMT
I've just run into the same problem - cheese trying to save a picture to the root /....jpg
I'm using openbox - but can't avoid using gnome based apps.
Looks like gnome developers never thinks their apps would be used outside their (bloated) desktop environment.
I would welcome a patch which defaults to the home directory if it can't find a sane path to store user data.
Preferably, it would prefer user variables before trying to use dconf based variables.

Comment by Doug Newgard (Scimmia) - Wednesday, 13 May 2015, 16:18 GMT
Status?

Loading...