Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38139 - [linux] 3.12.2 pctv 290e fails in linux

Attached to Project: Arch Linux
Opened by Robin Becker (replabrobin) - Saturday, 14 December 2013, 22:31 GMT
Last edited by Laurent Carlier (lordheavy) - Sunday, 29 December 2013, 13:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
PCTV 290e usb dvb devices fail in linux > 3.12.2 because of some upstream change.

Additional info:
* linux > 3.12.2
* config and/or log files etc.


Steps to reproduce:
Attach pctv 290e device and boot kernel linux 3.12.3; see errors like

kernel: tda18271 3-0060: creating new instance
kernel: tda18271_read_regs: [3-0060|M] ERROR: i2c_transfer returned: -19
kernel: Error reading device ID @ 3-0060, bailing out.
kernel: tda18271_attach: [3-0060|M] error -5 on line 1285
kernel: tda18271 3-0060: destroying instance

in logs. The video device(s) are present but don't work.

I have reported this to linux-media@vger.kernel.org; also have tested a
developer suggested fix

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0db3fa2741ad8371c21b3a6785416a4afc0cc1d4

which appears to correct the problem (at least for linux-3.12.4).
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Sunday, 29 December 2013, 13:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux-3.12.6

Loading...