Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38100 - [gajim] [gstreamer0.10-good] [farstream-0.1] crashes on startup after system update

Attached to Project: Arch Linux
Opened by chris (jugg) - Wednesday, 11 December 2013, 00:54 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 02 April 2014, 21:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Eric Belanger (Snowman)
Evangelos Foutras (foutrelis)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

After doing a $ sudo pacman -Syu

Now Gajim crashes on startup with the following error output

$ gajim
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
**
ERROR:fs-rtp-discover-codecs.c:126:debug_codec_cap: assertion failed: (gst_caps_get_size (codec_cap->rtp_caps) == 1)
Aborted (core dumped)

Additional info:
* package version(s)

$ pacman -Qs gajim
local/gajim 0.15.4-1
A full featured and easy to use Jabber client

* config and/or log files etc.

pacman.log

[2013-12-11 08:05] [PACMAN] Running 'pacman -Syu'
[2013-12-11 08:05] [PACMAN] synchronizing package lists
[2013-12-11 08:05] [PACMAN] starting full system upgrade
[2013-12-11 08:07] [PACMAN] removed sysvinit-tools (2.88-12)
[2013-12-11 08:07] [PACMAN] upgraded boost-libs (1.54.0-4 -> 1.55.0-2)
[2013-12-11 08:07] [PACMAN] upgraded akonadi (1.10.3-1 -> 1.11.0-1)
[2013-12-11 08:07] [PACMAN] upgraded boost (1.54.0-4 -> 1.55.0-2)
[2013-12-11 08:07] [PACMAN] upgraded sqlite (3.8.1-2 -> 3.8.2-1)
[2013-12-11 08:07] [PACMAN] upgraded fbreader (0.99.4-3 -> 0.99.4-4)
[2013-12-11 08:07] [PACMAN] upgraded libvpx (1.2.0-2 -> 1.3.0-1)
[2013-12-11 08:07] [PACMAN] upgraded ffmpeg (1:2.1.1-1 -> 1:2.1.1-2)
[2013-12-11 08:07] [PACMAN] upgraded firefox (25.0.1-1 -> 26.0-1)
[2013-12-11 08:07] [PACMAN] upgraded firefox-i18n-en-us (25.0.1-1 -> 26.0-1)
[2013-12-11 08:07] [PACMAN] upgraded freetype2 (2.5.1-1 -> 2.5.2-1)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10 (0.10.36-2 -> 0.10.36-3)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-base (0.10.36-1 -> 0.10.36-2)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-base-plugins (0.10.36-1 -> 0.10.36-2)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-good (0.10.31-3 -> 0.10.31-4)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-good-plugins (0.10.31-3 -> 0.10.31-4)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-ugly (0.10.19-7 -> 0.10.19-8)
[2013-12-11 08:07] [PACMAN] upgraded gstreamer0.10-ugly-plugins (0.10.19-7 -> 0.10.19-8)
[2013-12-11 08:07] [PACMAN] upgraded intel-tbb (4.2_20130725-1 -> 4.2_20131118-1)
[2013-12-11 08:07] [PACMAN] upgraded jasper (1.900.1-9 -> 1.900.1-10)
[2013-12-11 08:07] [PACMAN] upgraded libmikmod (3.3.3-1 -> 3.3.4-1)
[2013-12-11 08:07] [PACMAN] upgraded libpipeline (1.2.4-1 -> 1.2.5-1)
[2013-12-11 08:07] [PACMAN] upgraded libwbclient (4.1.2-1 -> 4.1.3-1)
[2013-12-11 08:07] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-12-11 08:07] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio. Please wait...
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Starting build: 3.10.23-1-lts
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-lts.img
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Starting build: 3.10.23-1-lts
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: smsmdtv
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2013-12-11 08:07] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-lts-fallback.img
[2013-12-11 08:07] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-12-11 08:07] [PACMAN] upgraded linux-lts (3.10.21-1 -> 3.10.23-1)
[2013-12-11 08:07] [PACMAN] upgraded lua (5.2.2-1 -> 5.2.3-1)
[2013-12-11 08:07] [PACMAN] upgraded lua51 (5.1.5-3 -> 5.1.5-4)
[2013-12-11 08:07] [PACMAN] upgraded luajit (2.0.2-1 -> 2.0.2-2)
[2013-12-11 08:07] [PACMAN] upgraded nss (3.15.3-1 -> 3.15.3.1-1)
[2013-12-11 08:07] [PACMAN] upgraded procps-ng (3.3.8-3 -> 3.3.9-1)
[2013-12-11 08:07] [PACMAN] upgraded python-setuptools (1.3.2-1 -> 1.4.2-1)
[2013-12-11 08:07] [PACMAN] upgraded python2-setuptools (1.3.2-1 -> 1.4.2-1)
[2013-12-11 08:07] [PACMAN] upgraded smbclient (4.1.2-1 -> 4.1.3-1)
[2013-12-11 08:07] [PACMAN] upgraded vlc (2.1.1-2 -> 2.1.2-1)
[2013-12-11 08:07] [PACMAN] upgraded wine (1.7.7-1 -> 1.7.8-1)
[2013-12-11 08:08] [PACMAN] upgraded wine-mono (0.0.8-1 -> 4.5.2-1)
[2013-12-11 08:08] [PACMAN] upgraded xfce4-terminal (0.6.2-1 -> 0.6.2-2)
[2013-12-11 08:08] [PACMAN] upgraded xmlto (0.0.25-2 -> 0.0.25-3)
[2013-12-11 08:08] [PACMAN] upgraded xorg-xinit (1.3.3-2 -> 1.3.3-3)

Steps to reproduce:

By reverting gstreamer0.10-good to the previous version resolves the problem

$ sudo pacman -U /var/cache/pacman/pkg/gstreamer0.10-good-0.10.31-3-i686.pkg.tar.xz
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 02 April 2014, 21:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in farstream-0.1-0.1.2-4. Testsuite passes with additional patches added in that version, aborts with errors from this bugreport without those.
Comment by chris (jugg) - Wednesday, 11 December 2013, 00:55 GMT
Sorry the bug summary should be regarding gstreamer0.10-good-0.10.31-4 not -3. Reverting to -3 fixes it.
Comment by Eric Belanger (Snowman) - Wednesday, 11 December 2013, 02:23 GMT
I can confirm the issue. It looks like a farstream issue as googling the error message pointed me to a couple bug reports saying that it's fixed in farstream 0.2.3. Probably the fix need to be backported to the farstream-0.1 package.
Comment by Jan de Groot (JGC) - Wednesday, 11 December 2013, 09:35 GMT
gstreamer0.10-good has switched to gstreamer-sdk. This includes changes that have been backported from 0.11/1.0, so it's likely that one of the changes in gstreamer0.10-good triggers a bug which has only been fixed in recent versions of farstream that target gstreamer 1.0.
Comment by Fabien Wang (fabienwang) - Wednesday, 11 December 2013, 09:58 GMT
Hello.

Another fix is to simple remove farstream-0.1 package and install farstream instead (which is version 0.2.3)

extra/farstream 0.2.3-1
Farstream (formerly Farsight) - Audio/Video Communications Framework
extra/farstream-0.1 0.1.2-2 [installed]
Audio/Video Communications Framework (legacy version)

For me it works.
Comment by Jan de Groot (JGC) - Wednesday, 11 December 2013, 11:16 GMT
gajim will not use farstream 0.2, as it needs 0.1 for video conversation. Replacing farstream with a newer major version just hides the problem, as you're disabling video conferencing.
Comment by Jan de Groot (JGC) - Wednesday, 11 December 2013, 20:49 GMT
http://cgit.collabora.com/git/farstream.git/commit/?id=50fffb08d941dce58ae48bf531faead8a4e22ed7

This commit fixes the crash. Note that there's a shitload of memleak fixes, both on 0.1 and 0.2 branch, so those might be interesting also.
Comment by Jan de Groot (JGC) - Thursday, 12 December 2013, 12:15 GMT
Fixes have been committed to farstream-0.1 svn trunk. I don't have my signing key available at this moment, so a release will follow.
Comment by Kevin Cox (kevincox) - Sunday, 05 January 2014, 03:58 GMT
Although this has been marked as fixed I still experience this issue.

I have installed:
- extra/gstreamer0.10-good 0.10.31-4
- extra/farstream-0.1 0.1.2-3
- extra/gajim 0.15.4-1

Upon starting a video chat gajim instantly crashes with the following log.

% gajim
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
**
ERROR:fs-rtp-discover-codecs.c:126:debug_codec_cap: assertion failed: (gst_caps_get_size (codec_cap->rtp_caps) == 1)
zsh: abort (core dumped) gajim
% echo $?
134
Comment by Kevin Cox (kevincox) - Monday, 06 January 2014, 19:37 GMT
Thanks for reopening.

Do you need any additional information? I experience the issue on both of my x64 computers with the above mentioned packages installed.

Cheers.
Comment by Sara Fauzia (sfauzia) - Saturday, 08 February 2014, 23:46 GMT
I am experiencing the same issue with pidgin. Upon trying to initiate a video chat, pidgin crashes with:

**
ERROR:fs-rtp-discover-codecs.c:126:debug_codec_cap: assertion failed: (gst_caps_get_size (codec_cap->rtp_caps) == 1)
zsh: abort (core dumped) pidgin

I have installed all the relevant gstreamer packages (including gstreamer0.10-good as the above poster) farstream 0.1.2-3, and pidgin 2.10.9-1. If there's any more information I can provide, please let me know.
Comment by Jeanbon (jeanbon) - Wednesday, 12 February 2014, 14:12 GMT
Exactly the same problem with pidgin 2.10.9-1 and gajim 0.15.4. I have installed all requiered gstreamer package, and when I'm trying to start a video call,
**
ERROR:fs-rtp-discover-codecs.c:126:debug_codec_cap: assertion failed: (gst_caps_get_size (codec_cap->rtp_caps) == 1)
Abandon (core dumped)

If there's any information I can provide, please let me know..
Comment by Harlem Bug (buggubug) - Friday, 28 March 2014, 16:07 GMT
Have the same problem with pidgin, like the poster before:
**
ERROR:fs-rtp-discover-codecs.c:126:debug_codec_cap: assertion failed: (gst_caps_get_size (codec_cap->rtp_caps) == 1)

I've tried it with farstream-0.1 0.1.2-3 and farstream-0.1 0.1.2-2

Is there any solution?

Loading...