Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38065 - [sofia-sip] telepathy-rakia connects but calls fail

Attached to Project: Arch Linux
Opened by ridams (ridams) - Sunday, 08 December 2013, 22:43 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 07 January 2018, 22:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
using Empathy (telepathy-rakia) aka sofia-sip can never make a call successfully (emission) , tested with getonsip.com.

but when we call a sip account in empathy (reception), empathy shows a dialog with answer , abort buttons but when we answer there is no connection.

- SIP registration succeeds normally of course.

Additional info:
* version 0.8.0-1
* my debug log (attached)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 07 January 2018, 22:33 GMT
Reason for closing:  Won't fix
Additional comments about closing:  removed from the repositories and dropped to the AUR
Comment by Paul (wegsehen) - Sunday, 12 January 2014, 14:58 GMT
I can confirm this.
No matter which number im calling, it just rings for me, but not on the other side. Registration sucessful, as well.
Comment by Ionut Biru (wonder) - Saturday, 25 January 2014, 20:36 GMT
please report upstream, there is nothing we can do here.
Comment by tim (mobybit) - Monday, 16 March 2015, 14:13 GMT
Same for me. No problems with the same version of telepathy-rakia in debian jessie and fedora 21. I think it's time for an update.
Comment by tim (mobybit) - Monday, 16 March 2015, 23:22 GMT
If I read this conversation correctly the bug is related to sofia-sip:

http://comments.gmane.org/gmane.comp.freedesktop.telepathy/6159

They still providing a patch here:

https://bugzilla.redhat.com/attachment.cgi?id=800563&action=diff&context=patch&collapsed=&headers=1&format=raw

If this is a possible solution for the problem described here it will be wonderfull if someone could add it. Thanks!
Comment by tim (mobybit) - Tuesday, 17 March 2015, 20:52 GMT
Okay. I think that's the problem. After compiling sofia-sip with the patch the problem disappears.
Comment by tim (mobybit) - Wednesday, 18 March 2015, 02:59 GMT
More information you can find here http://sourceforge.net/p/sofia-sip/bugs/121/. It seems sofia-sip is not maintained upstream at the moment so we have to apply the patch manually.
Comment by tim (mobybit) - Saturday, 28 March 2015, 22:12 GMT
I think we have to change the title to [sofia-sip]. It is an upstream bug but we have to solve them here by applying the patch.
Comment by tim (mobybit) - Monday, 06 April 2015, 04:19 GMT
Bug 44439 seems to be duplicate.
Comment by AngryUbuntuNerd (AngryUbuntuNerd) - Monday, 24 April 2017, 16:54 GMT
I just ran into this same problem again.

It is still not fixed upstream in Sofia-SIP, and does not seem it ever will (last update 2011-03-11).

The supplied patch fixed the problem for me. Is there any chance we can permanently apply this patch to the Arch package?

Loading...