Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38056 - [phpmyadmin] creates a zombie process ( httpd ) after stopping apache and mariadb services

Attached to Project: Community Packages
Opened by patrick (potomac) - Sunday, 08 December 2013, 01:54 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 09 March 2014, 16:14 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I use phpmyadmin ( package phpmyadmin 4.0.10-1 ), I usualy start manually apache and mariadb :

systemctl start mysqld
systemctl start httpd

and I stop manually apache and mariadb :

systemctl stop httpd
systemctl stop mysqld

but a zombie process appears just after the shutdown of httpd and mysqld : httpd ( the owner of the process is "http" user ), the bug is triggered only if I use phpmyadmin,

systemd is unable to shutdown this zombie process ( the command "systemctl stop httpd" ), the only way is to do a "killall -9 httpd",

If I don't use phpmyadmin then there is no zombie process ( httpd ) after the shutdown of httpd and mariadb services by systemd,


Additional info:
* package version(s) phpmyadmin 4.0.10-1, apache 2.2.25-1, mariadb 5.5.34-3

* config and/or log files etc.


Steps to reproduce:
- start manually apache and mariadb with systemd
- use phpmyadmin
- stop manually apache and mariadb with systemd
- a zombie process ( httpd ) will appear
- if you see no zombie process then restart the procedure, because it's sometimes a random bug
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Sunday, 09 March 2014, 16:14 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Sunday, 08 December 2013, 07:57 GMT
Sounds like an apache bug. And if systemd is not able to stop the service there might be an issue, too.
Comment by Jelle van der Waa (jelly) - Sunday, 22 December 2013, 13:04 GMT
Have you tried reproducing this with an older phpmyadmin version?
Comment by patrick (potomac) - Sunday, 22 December 2013, 14:58 GMT
I use the last version of the package phpmyadmin ( 4.1.1-1 )

the bug is still here, a zombie process ( httpd, owned by "http" user ) who doesn't want to be closed if myphpadmin was used, a "killall -9 httpd" is the only solution to close this process

Comment by Sebastiaan Lokhorst (lonaowna) - Sunday, 09 March 2014, 09:02 GMT
I cannot reproduce this with Apache 2.4, it might be fixed. Can you confirm?
Comment by patrick (potomac) - Sunday, 09 March 2014, 16:09 GMT
yes, the bug seems resolved with apache 2.4

Loading...