Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38053 - [grub] missing file on install

Attached to Project: Arch Linux
Opened by Christian Hesse (eworm) - Saturday, 07 December 2013, 21:06 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 21 December 2013, 20:51 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

Description:
Updated to latest grub package, now installing grub to disk fails:

# grub-install /dev/sda
grub-install: error: cannot open `/usr/lib/grub/i386-pc/gpt.mod': No such file or directory.

Additional info:
grub 1:2.00.1282.g5ae5c54-1

System ist x86_64, installed to a GPT partitioned disk.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 21 December 2013, 20:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.02-beta1
Comment by Jamin Collins (jamincollins) - Saturday, 07 December 2013, 22:30 GMT
This same type of error is occurring with DOS style partition tables.

# grub-install --recheck /dev/sdb
grub-install: error: cannot open `/usr/lib/grub/i386-pc/msdos.mod': No such file or directory

This was working a few days ago.
Comment by Jamin Collins (jamincollins) - Sunday, 08 December 2013, 00:55 GMT
Further testing indicates that the file it's actually wanting is part_XXXX where XXXX is either the msdos.mod or gpt.mod. Trying to track down the change responsible for this.
Comment by Jamin Collins (jamincollins) - Sunday, 08 December 2013, 01:54 GMT
Appears to be the generated grub-mkimage command that is wrong. Manually running the command with the correct entry (part_msdos.mod or part_gpt.mod) seems to work. Still looking for the actual change responsible.
Comment by Jamin Collins (jamincollins) - Sunday, 08 December 2013, 03:49 GMT
Appears to be the generated grub-mkimage command that is wrong. Manually running the command with the correct entry (part_msdos.mod or part_gpt.mod) seems to work. Still looking for the actual change responsible.
Comment by André Fettouhi (A.Fettouhi) - Sunday, 08 December 2013, 22:19 GMT
I can confirm this bug as well with this new version of grub.
Comment by Raymond Ambs (rambs) - Sunday, 08 December 2013, 22:26 GMT
Found the same problem when trying a fresh install
Comment by Andrej Podzimek (andrej) - Tuesday, 10 December 2013, 19:59 GMT
The same problem here. msdospart.mod and part_msdos.mod are there, but there's no msdos.mod.

Edit 0: This is not a GPT system, it's a plain old BIOS layout (both in terms of firmware and partitioning). But I have the same problem, just s/gpt\.mod/msdos.mod/
Edit 1: As a stupid workaround, I did cd /usr/lib/grub/i386-pc/; ln -s part_msdos.mod msdos.mod; and it helped, i.e., GRUB installed itself and my machine survived a reboot. That's not a permanent solution, but it might come in handy if you desperately need to install GRUB right here right now.
Comment by Unai Uribarri (unaiur) - Tuesday, 17 December 2013, 12:35 GMT
Same problem here. I've tried:
ln -s part_gpt.mod gpt.mod

Now grub installs, but the system doesn't boot:

It says something like:

Module part_gpt.mod already loaded.
Aborted. Press any key to exit...
Comment by Unai Uribarri (unaiur) - Tuesday, 17 December 2013, 12:38 GMT
What harmless module can I link from gpt.mod to recover my system?
Comment by Christian Hesse (eworm) - Tuesday, 17 December 2013, 16:08 GMT
Looks like we have to apply parts of commit f585c905054b8c74e6e0a67341e84accfb816912 (fix partition module names when /boot is on diskfilter).
http://git.savannah.gnu.org/cgit/grub.git/commit/?id=f585c905054b8c74e6e0a67341e84accfb816912

I've build my package with the attached patch. It also fixes two other bugs currently open.
Comment by Christian Hesse (eworm) - Thursday, 19 December 2013, 10:40 GMT
Grub 2.02-beta1 has been tagged in git... Perhaps this is a good chance to update the package to something different than just a random git commit.

Loading...