Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#38051 - [Grub] errors during execution of "grub-mkconfig" from grub

Attached to Project: Pacman
Opened by patrick (potomac) - Saturday, 07 December 2013, 18:11 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 07 December 2013, 18:19 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.1.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info: I did a "pacman -Syu" and grub package was updated :

grub-2.00.5086-1 ---> grub 1:2.00.1282.g5ae5c54-1

so I run 2 scripts in order to reinstall grub and update configs files :

- grub-install --recheck /dev/sdc
output : "Installation finished. No error reported."

then :

grub-mkconfig -o /boot/grub/grub.cfg

and I see errors messages :

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
error: out of memory.
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 194
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/grub.cfg.new file attached.done

so it's seems that grub package has a problem, something is wrong with the file grub-mkconfig

my system: archlinux 64 bits
4 Gb ram

Steps to Reproduce:
- you must have already a grub installation ( package grub-2.00.5086-1 )
- then do a "pacman -Syu" in order to have the last grub package ( grub 1:2.00.1282.g5ae5c54-1 )
- reinstall grub ( grub-install --recheck /dev/sdX )
- regenerate the gruf.cfg file ( grub-mkconfig -o /boot/grub/grub.cfg )
- error messages will be displayed
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 07 December 2013, 18:19 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#37904 
Comment by killruana (killruana) - Thursday, 12 December 2013, 16:57 GMT
Same error with a fresh installation of grub.

In grub.cfg.new, a submenu section is not closed:

### BEGIN /etc/grub.d/10_linux ###
[snip]
submenu 'Advanced options for Arch Linux' $menuentry_id_option 'gnulinux-advanced-85d50a12-35af-425b-99cd-bc2aede8486f' {

### END /etc/grub.d/10_linux ###

Loading...