Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38041 - grub 1:2.00.1282.g5ae5c54-1 will not generate grub.cfg file syntax errors

Attached to Project: Arch Linux
Opened by AndrzejL (AndrzejL) - Friday, 06 December 2013, 20:09 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 07 December 2013, 08:58 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Name : grub
Version : 1:2.00.1282.g5ae5c54-1
Description : GNU GRand Unified Bootloader (2)
Architecture : i686
URL : https://www.gnu.org/software/grub/
Licenses : GPL3
Groups : None
Provides : grub-common grub-bios grub-efi-i386
Depends On : sh xz gettext device-mapper
Optional Deps : freetype2: For grub-mkfont usage [installed]
<snipped>
Required By : grub2-theme-archxion
Optional For : None
Conflicts With : grub-common grub-bios grub-efi-i386 grub-legacy
Replaces : grub-common grub-bios grub-efi-i386
Installed Size : 22039.00 KiB
Packager : Tobias Powalowski
Build Date : Mon 25 Nov 2013 07:47:33 GMT
Install Date : Fri 06 Dec 2013 19:42:31 GMT
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature

Upgraded and wanted to refresh my /boot/grub/grub.cfg and got this:

Generating grub configuration file ...
Found theme: /boot/grub/themes/Archxion/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
error: out of memory.
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 179
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/grub.cfg.new file attached.done

Similar errors on other machines.

Kind regards.

Andrzej

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 07 December 2013, 08:58 GMT
Reason for closing:  Duplicate
Additional comments about closing:  37904
Comment by John (graysky) - Friday, 06 December 2013, 20:12 GMT
Known issue with known workaround: add the following to /etc/default/grub

# fix broken grub.cfg gen
GRUB_DISABLE_SUBMENU=y
Comment by AndrzejL (AndrzejL) - Friday, 06 December 2013, 20:16 GMT
That worked just fine.

Thanks John.

Kind regards.

Andrzej
Comment by Karol Błażewicz (karol) - Friday, 06 December 2013, 23:39 GMT
Is it a duplicate of  FS#37904  ?
Comment by Keshav Amburay (the.ridikulus.rat) - Saturday, 07 December 2013, 05:41 GMT
@karol: Yes, it is a duplicate of  FS#37904  .

Loading...