Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#38010 - [mono] Random startup failures

Attached to Project: Arch Linux
Opened by Please Delete (balticer) - Wednesday, 04 December 2013, 12:25 GMT
Last edited by Isenmann Daniel (ise) - Thursday, 16 January 2014, 16:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
Mono applications not starting up with last nvidia-drivers (331.20-2). The process is running but no UI. Also sometimes an unamed defunc child process appears with starting keepass. It's looks like an race condition/deadlock in keepass and/or mono!?
Closed by  Isenmann Daniel (ise)
Thursday, 16 January 2014, 16:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with the latest nvidia driver, proofed by the latest comments.
Comment by Please Delete (balticer) - Wednesday, 04 December 2013, 14:14 GMT
I've attached an strace of an failure start. The application hangs on "futex(0x97ea20, FUTEX_WAIT_PRIVATE, 0, NULL"

regards
Kai
Comment by Timothy Redaelli (tredaelli) - Thursday, 05 December 2013, 23:10 GMT
Which desktop manager are you using?
Comment by Please Delete (balticer) - Friday, 06 December 2013, 07:11 GMT
Hi,

Gnome 3.10.1 and also the latest nvidia drivers from the Arch Repo.

regards
Kai
Comment by Timothy Redaelli (tredaelli) - Friday, 06 December 2013, 12:51 GMT
Hi,
can you try to extract this file and to do:
make -C keepass-test run

I think it's the same problem of http://forum.manjaro.org/index.php?topic=8253.0
Comment by Please Delete (balticer) - Friday, 06 December 2013, 21:57 GMT
Hi,

tryed it 4+ times and it works for now. But is rather an workaround instead of a fix, isn't? I has found stuff that it's maybe related to the current nvidia-drivers ->

https://www.smuxi.org/issues/show/903
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728743

/edit
Same with other mono apps, like banshee or monodevelop.

regards
Kai
Comment by Steve Zalek (taotedice) - Saturday, 07 December 2013, 18:41 GMT
Keepass will no longer start up for me as well. I am running an up-to-date x64 Arch system with an Xfce4 desktop.

I recently updated to the latest linux kernel (3.12.3-1) and Nvidia driver set (v331.20-2); keepass had been working until this update.
Comment by Mikey D (ProfessorKaos64) - Monday, 09 December 2013, 11:09 GMT
On this thread now, thanks for linking me Timothy. I suppose I am in a similar boat. This will teach me to keep an update .kdb file ... I'm fairly certain this is due to a mono issue. If You need file comparisons to my Fedora installation. Please let me know.
Comment by Hermann Zahnweh (eigengrau) - Friday, 13 December 2013, 09:37 GMT
The starting-up failures only seem to happen when a process in run directly from within a window manager session. E.g. tomboy consistenly will stall when I start it from the GNOME shell directly. However, when I open a terminal window and start it from there, it'll start up fine.

Might be related: Some people seeing this Mono thing also see a lot of non-mono processes zombifying with the latest Nvidia blob. Compare https://bbs.archlinux.org/viewtopic.php?pid=1359745

Is anyone also seeing quirks when running Firefox? When I start it from within the Gnome shell, the window will just vanish without trace. Running from a terminal works normally.
Comment by nsf (nsf) - Friday, 13 December 2013, 23:16 GMT
Don't know if it's related or not. On my machine after recent updates all mono apps are freezing. I can't even run a compiler, e.g.:

[nsf @ Test]$ dmcs -h
error CS2007: Unrecognized command-line option: `-h'

And the process never returns. Maybe a kernel incompatibility with mono runtime or something. Perhaps they've fixed it in git already. Will try installing mono-git for now.
Comment by nsf (nsf) - Friday, 13 December 2013, 23:25 GMT
Adding to the above, indeed as reported above strace ends with this, seems like a typical deadlock:

write(1, "error CS2007: Unrecognized comma"..., 52error CS2007: Unrecognized command-line option: `-h') = 52
write(1, "\n", 1
) = 1
sched_yield() = 0
tgkill(2227, 2228, SIGPWR) = 0
futex(0x97ea20, FUTEX_WAIT_PRIVATE, 0, NULL
Comment by nsf (nsf) - Friday, 13 December 2013, 23:39 GMT
Same thing on mono-git. Surprisingly enough it was able to build itself. Have no idea how.
Comment by nsf (nsf) - Saturday, 14 December 2013, 18:45 GMT
Hm.. after -Syu it works now. And this time there were no critical packages, besides xorg. Maybe it's indeed related to some weird nvidia driver issues. But really hard to imagine how that happens.
Comment by Alexander Peltzer (alexpe87) - Thursday, 19 December 2013, 09:45 GMT
I can't confirm this. I just upgraded everything to current state (2013-12-19) and still have these problems.
Comment by nsf (nsf) - Tuesday, 24 December 2013, 05:19 GMT
Yes, the bug appears again. All mono apps are hanging. Really sad one.
Comment by Jan K. (Artran) - Saturday, 28 December 2013, 12:38 GMT
I've the same issue (with games from Steam like Rogue Legacy, FEZ and Jack the Lumber). Mono version 3.2.3, Gnome 3.10.2.1, NVidia 331.20. It appears randomly, sometimes helps to run application from terminal (but unfortunatelly not allways).
Comment by nsf (nsf) - Saturday, 28 December 2013, 12:42 GMT
Guys, for now the only really working solution is to rollback to previous nvidia driver and linux kernel. I'm using linux-3.11.1 and nvidia-325.15, everything works smoothly. Yes, it is indeed a problem with nvidia driver. The other bug about firefox segfaults is the same problem. After rolling back both problems disappear.
Comment by Alexander Peltzer (alexpe87) - Saturday, 28 December 2013, 12:57 GMT
@nsf As much as I appreciate your tip, I think this can not be the true and final solution for these issues. I hope this gets fixed ASAP, since it's really annoying for now.
Comment by Thomas Hebb (tchebb) - Monday, 13 January 2014, 12:58 GMT
I can no longer reproduce this issue using the just-released 331.38 driver. It appears to be fully resolved, as was indicated by an NVIDIA employee at https://devtalk.nvidia.com/default/topic/633706/l/r/2/#4066578
Comment by Alexander Peltzer (alexpe87) - Monday, 13 January 2014, 13:19 GMT
Fortunately, I can confirm what Thomas Hebb just posted, that the error seems to be gone on all my machines running the latest nVidia driver 331.38. For me this seems to be fixed by now and I wasn't able to reproduce the error anymore.
Comment by Jan K. (Artran) - Monday, 13 January 2014, 20:02 GMT
My issues with games on Steam are also gone after updating the NVidia driver. I'd also problem with freezing of Firefox. Now it runs well. So it was most likely connected.

Loading...