Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37956 - [freetype2] header location changed to just /usr/include/freetype2

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Saturday, 30 November 2013, 08:45 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 30 November 2013, 08:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The freetype2 header files used to be under /usr/include/freetype2/freetype/ . They were typically used, for instance, as "#include <freetype/freetype.h>" and compiled with "-I/usr/include/freetype2/". This is consistent with what the freetype2 pkg-config file gives.

This appears to have changed with freetype2-2.5.1. Thus software that used to compile fine against freetype2 now fails to do so. That seems a bit strange for a 2.5.0 ==> 2.5.1 upgrade...

Is this change supposed to be permanent or is it a misunderstanding? Should we update the paths in all #include <freetype/freetype.h>?
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 30 November 2013, 08:54 GMT
Reason for closing:  Not a bug
Comment by Gaetan Bisson (vesath) - Saturday, 30 November 2013, 08:47 GMT
For the record, one such piece of software is inkscape.
Comment by Jan Alexander Steffens (heftig) - Saturday, 30 November 2013, 08:50 GMT
The correct way to link against freetype is to use freetype-config or pkg-config for the CFLAGS and libs, and to use includes like the following in source files:

#include <ft2build.h>
#include FT_FREETYPE_H

Using <freetype/freetype.h> is wrong.

See my mail to arch-dev-public: https://mailman.archlinux.org/pipermail/arch-dev-public/2013-November/025678.html
Comment by Andreas Radke (AndyRTR) - Saturday, 30 November 2013, 08:53 GMT
I've already fixed inkscape.

Loading...