Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37920 - [liferea] segfaults

Attached to Project: Arch Linux
Opened by indianahorst (indianahorst) - Tuesday, 26 November 2013, 18:27 GMT
Last edited by Eric Belanger (Snowman) - Thursday, 06 February 2014, 20:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Installed Liferea, started it the first time. Went flawlessly.
Closed the window and started it again a few minutes later. Liferead crashed with the following output:


Additional info:
* package version(s)
extra/liferea 1.10.3-1
System: Archlinux x86_64
Kernel: 3.12.1-1-ARC

Steps to reproduce: see above

$ liferea
(liferea:30942): libnotify-WARNING **: Failed to connect to proxy
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
sh: /usr/lib/nspluginwrapper/i386/linux/npviewer: No such file or directory
*** NSPlugin Wrapper *** ERROR: failed to execute NSPlugin viewer
java version "1.7.0_45"
OpenJDK Runtime Environment (IcedTea 2.4.3) (ArchLinux build 7.u45_2.4.3-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** WARNING:(/tmp/n/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
sh: /usr/lib/nspluginwrapper/i386/linux/npviewer: No such file or directory
*** NSPlugin Wrapper *** ERROR: failed to execute NSPlugin viewer
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** WARNING:(/tmp/n/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))

(liferea:30942): Gtk-CRITICAL **: gtk_tree_store_get_path: assertion 'iter->stamp == priv->stamp' failed

(liferea:30942): Gtk-CRITICAL **: gtk_tree_view_set_cursor_on_cell: assertion 'path != NULL' failed

(liferea:30942): Gtk-CRITICAL **: gtk_tree_view_scroll_to_cell: assertion 'tree_view->priv->tree != NULL' failed
Segmentation fault (core dumped)
This task depends upon

Closed by  Eric Belanger (Snowman)
Thursday, 06 February 2014, 20:27 GMT
Reason for closing:  Works for me
Comment by Eric Belanger (Snowman) - Tuesday, 26 November 2013, 22:00 GMT
It looks like the problem is caused by nspluginwrapper. If you uninstall it, does liferea works fine?
Comment by indianahorst (indianahorst) - Tuesday, 26 November 2013, 22:13 GMT
nspluginwrapper is not installed!
Comment by Eric Belanger (Snowman) - Wednesday, 27 November 2013, 03:02 GMT
Here I don't have the seg fault. The only output I get is posted below. I can't find any mention of nsplugin in liferea's code. Probably something on your system if trying to use nsplugin. Try running 'liferea --debug-all' maybe it'll give more info. Is your system up-to-date? Also, what browsers are installed?

$ liferea

(liferea:21702): libnotify-WARNING **: Failed to connect to proxy
java version "1.7.0_45"
OpenJDK Runtime Environment (IcedTea 2.4.3) (ArchLinux build 7.u45_2.4.3-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

(liferea:21702): Gtk-CRITICAL **: gtk_tree_store_get_path: assertion 'iter->stamp == priv->stamp' failed

(liferea:21702): Gtk-CRITICAL **: gtk_tree_view_set_cursor_on_cell: assertion 'path != NULL' failed

(liferea:21702): Gtk-CRITICAL **: gtk_tree_view_scroll_to_cell: assertion 'path != NULL || column != NULL' failed

Comment by Eric Belanger (Snowman) - Tuesday, 14 January 2014, 01:47 GMT
Is it fixed in liferea-1.10.4-1 ?

Loading...