Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37884 - [icewm] failure to shutdown/reboot

Attached to Project: Arch Linux
Opened by ybsar (ybsar) - Saturday, 23 November 2013, 08:48 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 31 May 2014, 01:17 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Shutdown/Reboot IceWM menu entries are unresponsive.

Package version: icewm-1.3.8-1

Config file ~/.icewm/preferences:
ShutdownCommand="systemctl poweroff"
RebootCommand="systemctl reboot"

Additional notes:
The above commands work fine when typed in an xterm.
Using absolute path /usr/bin/systemctl does not help.

Steps to reproduce: click it

Temporary work-around: downgrade to icewm-1.3.7-3
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 31 May 2014, 01:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  icewm-1.3.8-2
Comment by Eric Belanger (Snowman) - Saturday, 23 November 2013, 17:26 GMT
Please report that upstream.
Comment by ybsar (ybsar) - Sunday, 24 November 2013, 06:30 GMT Comment by Tobias Mueller (sirtobi) - Friday, 30 May 2014, 20:54 GMT
There's a patch which works for me...

https://sourceforge.net/p/icewm/bugs/911/

Would be great if it could be included...

Loading...