Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37847 - [grub] grub testing fails during build with "can't set 16x16 font size"

Attached to Project: Arch Linux
Opened by Markus M. May (triplem) - Tuesday, 19 November 2013, 20:52 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 25 November 2013, 08:17 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
grub does not build with unifont-6.3.

This seems to be an upstream bug (see http://savannah.gnu.org/bugs/?40330)

Additional info:
* package version(s)

unifont-6.3
grub testing

* buildlog

./build-grub-mkfont -o unicode.pf2 /usr/share/fonts/misc/unifont.bdf
build-grub-mkfont: error: can't set 16x16 font size: Freetype error 23: invalid pixel size.
Makefile:37983: recipe for target 'unicode.pf2' failed
make[2]: *** [unicode.pf2] Error 1
make[2]: Leaving directory '/build/grub/src/grub-2.00-bios'
Makefile:30315: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/build/grub/src/grub-2.00-bios'
Makefile:24839: recipe for target 'all' failed
make: *** [all] Error 2


Steps to reproduce:
makepkg on grub in testing

Fix:
add the following source:
http://unifoundry.com/unifont-5.1.20080820.bdf.gz

and additionally the following two lines to the end of the prepare():

msg "Avoid problem with unifont during compile of grub (see http://savannah.gnu.org/bugs/?40330)";
cp ${srcdir}/unifont-5.1.20080820.bdf ${srcdir}/grub-${_pkgver}/unifont.bdf
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 25 November 2013, 08:17 GMT
Reason for closing:  Fixed
Comment by Keshav Amburay (the.ridikulus.rat) - Thursday, 21 November 2013, 08:56 GMT
@triplem: Thanks for the heads-up. I added the fix to AUR grub-git pkg (maintained by me).

Loading...