Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#3779 - xcompmgr in pacman - weird

Attached to Project: Pacman
Opened by Travis Willard (Cerebral) - Saturday, 14 January 2006, 20:41 GMT
Task Type Bug Report
Category
Status Closed
Assigned To No-one
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've successfully upgraded to xorg7 in [testing] however, when I run a pacman -Syu I get this:

xcompmgr requires xorg, but it is in IgnorePkg. Install anyway? [Y/n] n
error: cannot resolve dependencies for "xcompmgr"

(I've put xorg in IgnorePkg because of it, but that obviously didn't help)

It seems to be, for whatever reason, pulling the dependancies from xcompmgr 1.1.1-1 instead of 1.1.1-2, even though I have 1.1.1-2 installed from [testing]

This only happens I have [testing] defined _after_ [current] in pacman.conf, but it doesn't happen for any package except xcompmgr. I get alot of messages about "installed version of package X is newer than in repo" which I expect, since I've installed alot from testing... shouldn't I get this message for xcompmgr too instead of it trying to re-install 1.1.1-1?

# pacman -Qi xcompmgr
Name : xcompmgr
Version : 1.1.1-2
Depends On : libxcomposite libxdamage libxrender

# pacman -Si xcompmgr
Repository : current
Name : xcompmgr
Version : 1.1.1-1
Groups : None
Provides : None
Depends On : xorg>=6.8.0
Conflicts With : xapps
Replaces : xapps
Size (compressed) : 17103
Description : Composite Window-effects manager for X.org
MD5 Sum : f29a4a5f4c11d09b3b5d8defcd234c4e

Repository : testing
Name : xcompmgr
Version : 1.1.1-2
Groups : None
Provides : None
Depends On : libxcomposite libxdamage libxrender
Conflicts With : xapps
Replaces : xapps
Size (compressed) : 15338
Description : Composite Window-effects manager for X.org
MD5 Sum : 07b3a42916cf3f7842a7fba9f5cbc4ee
This task depends upon

Closed by  arjan timmerman (blaasvis)
Saturday, 11 February 2006, 15:42 GMT
Reason for closing:  Not a bug
Comment by Travis Willard (Cerebral) - Saturday, 14 January 2006, 20:44 GMT
Forgot to mention, when I remove xorg from IgnorePkg I get this:


:: pkg: local (x.x.x) appears to be newer than repo (current/x.x.x)
(( repeats lots of times for all the packages I've installed from [testing] except message does NOT appear for xcompmgr ))
:: xorg conflicts with ttf-bitstream-vera. Remove ttf-bitstream-vera? [Y/n] y

Remove: ttf-bitstream-vera

Targets: xorg-11R6.8.2-6 xcompmgr-1.1.1-1

For some reason, it doesn't realize xcompmgr-1.1.1-2 is newer than xcompmgr-1.1.1-1
Comment by Jan de Groot (JGC) - Sunday, 15 January 2006, 11:45 GMT
You're using testing below current in pacman.conf, which breaks every logic that pacman uses to install these things from testing. I won't optimize dependencies for people who use testing in this way.
Comment by Travis Willard (Cerebral) - Sunday, 15 January 2006, 13:02 GMT
Hm.. okay. When I first came to Arch, I had it recommended to me that if I were to install anything from testing to use it in this manner so only packages I specified as testing/pkgname would install from that repo. Mind you, I don't think it was a dev who recommended it. :) Is there a better way to selectively install packages from testing without updating to everything that's in the repo?

Anywho, all I'm wondering is why pacman doesn't ignore xcompmgr and print a warning like it does every other package where I've installed a newer version than exists in current... this also happens if I disable testing now (ie. comment it out in pacman.conf) after having installed these apps from it.

No big deal anyway; after tinkering with xcompmgr I found it really doesn't like proprietary ATI drivers, so it's gone now. :P Thanks for your time.

Loading...