Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37773 - [bluez] Can't send nor receive any files

Attached to Project: Arch Linux
Opened by Reda Lazri (rAX) - Friday, 15 November 2013, 09:48 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 22 January 2014, 22:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Tom Gundersen (tomegun)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

I'm a GNOME(3.10) user and I've never been able to use the Bluetooth section in GCC to send nor receive anything. Paring works, everything seems to be fine until I try to send files, then it gives me this message in the terminal:

Acquiring proxy failed: Error calling StartServiceByName for org.bluez.obex: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /bin/false exited with status 1

Bastien Nocera one of Bluez's devs said:

"Ask your package maintainers to pick up the "non-systemd session" patch from the Fedora package. It's not upstream."

And recently blogged: http://www.hadess.net/2013/11/bluetooth-file-sharing-obexpush-in.html

I haven't been able to test it but he says that it should fix the issue.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce: Enable bluetooth on computer and device, send a file, confirm, watch it fail.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 22 January 2014, 22:12 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Wednesday, 20 November 2013, 15:33 GMT
Please check bluez 5.11-1 in testing with that patch added.
Comment by Reda Lazri (rAX) - Thursday, 21 November 2013, 07:34 GMT
Thank you! Sending to devices works now. Receiving from devices however is still broken. And pairing for the first time works but after that bluetoothhd segfaults:

[ 987.561208] input: 30:85:A9:5A:BB:AA as /devices/virtual/input/input19
[ 987.688442] bluetoothd[2764]: segfault at 0 ip 000000000041d66c sp 00007fff57802260 error 4 in bluetoothd[400000+98000]
Comment by Andreas Radke (AndyRTR) - Sunday, 24 November 2013, 11:36 GMT
Can you please check different kernels and maybe apply that patch back to an older bleuz5 version to verify if it is caused by either
userland bluez or the kernel bluetooth stack.
Comment by Reda Lazri (rAX) - Thursday, 28 November 2013, 14:02 GMT
I used Linux-ck 3.12.1 and it failed. I had the older vanilla kernel 3.11.1, everything works with it flawlessly. Updated it to 3.12.1 as well and it failed like -ck. So it probably has to do with the kernel.
Comment by Andreas Radke (AndyRTR) - Saturday, 30 November 2013, 15:19 GMT
Assigning also to our kernel maintainer.

@Reda, please check for known upstream kernel bug reports or file a new one.
Comment by Ihor (Ihorko) - Tuesday, 24 December 2013, 18:07 GMT
I'm not sure if it behaviour according to bluez documentation. But I was able to send file via bluetooth with executing additional command:
sudo rfcomm connect hci0 <bluetooth MAC>

In my opinion NetworkManager is not updated to support bluez5.
Comment by Dave Seff (Adelie) - Sunday, 29 December 2013, 21:01 GMT
Not sure if this is related, But I was having an issue recieving files, I'm using KDE and bluez 5.13-1:

journalctl -b
Dec 29 12:45:26 mercury obexd[5438]: PUT(0x2), (null)(0xffffffff)
Dec 29 12:45:26 mercury obexd[5438]: open(/tmp/IMG_20131225_200111.jpg): Operation not permitted (1)
Dec 29 12:45:26 mercury obexd[5438]: PUT(0x2), FORBIDDEN(0x43)
Dec 29 12:45:26 mercury obexd[5438]: DISCONNECT(0x1), (null)(0xffffffff)
Dec 29 12:45:26 mercury obexd[5438]: DISCONNECT(0x1), SUCCESS(0x20)
Dec 29 12:45:26 mercury obexd[5438]: disconnected: Transport got disconnected
Dec 29 12:48:45 mercury obexd[5438]: CONNECT(0x0), (null)(0xffffffff)

Seems odd that I would have a permission issue in /tmp. /tmp for me is mode 1777, which is correct.
Comment by Alex Fiestas (afiestas) - Friday, 03 January 2014, 15:30 GMT
The issue with BlueDevil should be fixed (KDE).
Comment by Andreas Radke (AndyRTR) - Monday, 20 January 2014, 16:20 GMT
status?
Comment by Reda Lazri (rAX) - Monday, 20 January 2014, 17:09 GMT
I was offline almost the entire time. I'm performing the updates now, I'll test again and look for/report the bug upstream. Sorry for the delay.
Comment by Reda Lazri (rAX) - Wednesday, 22 January 2014, 21:33 GMT
So today I sat with it to test it properly after the updates and guess what! Everything works!
I tested with 3.11 as well as 3.12.8-1 and Bluez 5.14-1. It fails once or twice some time but no segfaults, just the pairing button in G-C-C turns off and on. But sending to the computer now works! \o/

Loading...