Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37738 - [bluez] bluetoothd SEGFAULT on a mouse's initiative connect

Attached to Project: Arch Linux
Opened by PT. Ma. (BOYPT) - Tuesday, 12 November 2013, 11:18 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 20 January 2014, 16:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

This bug exists for a time.

Additional info:
* package version(s)

bluez-*.5.10-3-x86_64

* config and/or log files etc.


Steps to reproduce:

1. Configure a bluetooth (from KDE/bluedevil), the mouse works.
2. shutdown the mouse, turn on again.
3. bluetoothd crashes with segfault.

Log:

Nov 12 18:41:57 pt-laptop systemd[1]: Started Bluetooth service.
Nov 12 18:41:57 pt-laptop bluetoothd[4790]: Starting SDP server
Nov 12 18:41:57 pt-laptop bluetoothd[4790]: Bluetooth management interface 1.3 initialized
Nov 12 18:41:57 pt-laptop bluetoothd[4790]: Endpoint registered: sender=:1.31 path=/MediaEndpoint/A2DPSource
Nov 12 18:41:57 pt-laptop bluetoothd[4790]: Endpoint registered: sender=:1.31 path=/MediaEndpoint/A2DPSink
Nov 12 18:43:00 pt-laptop bluetoothd[4790]: Access denied: Message did not receive a reply (timeout by message bus)
Nov 12 18:43:00 pt-laptop systemd-coredump[4864]: Process 4790 (bluetoothd) dumped core.
Nov 12 18:43:00 pt-laptop systemd[1]: bluetooth.service: main process exited, code=dumped, status=11/SEGV
Nov 12 18:43:00 pt-laptop systemd[1]: Unit bluetooth.service entered failed state.


Repack with options=(debug !strip) in PKGBUILD, and start bluetoothd from gdb, the backtrace is:

Program received signal SIGSEGV, Segmentation fault.
0x000000000043db74 in agent_auth_cb (agent=<optimized out>, derr=0x7fffffffe2c0, user_data=0x6d1510) at src/adapter.c:4354
4354 struct service_auth *auth = adapter->auths->head->data;
(gdb) backtarce
Undefined command: "backtarce". Try "help".
(gdb) bt
#0 0x000000000043db74 in agent_auth_cb (agent=<optimized out>, derr=0x7fffffffe2c0, user_data=0x6d1510) at src/adapter.c:4354
#1 0x000000000043c615 in agent_unref (agent=0x6d8700) at src/agent.c:227
#2 0x000000000043db94 in agent_auth_cb (agent=<optimized out>, derr=0x7fffffffe310, user_data=0x6d1510) at src/adapter.c:4361
#3 0x000000000043c672 in simple_agent_reply (call=<optimized out>, user_data=0x6da020) at src/agent.c:326
#4 0x00007ffff78a2bd2 in ?? () from /usr/lib/libdbus-1.so.3
#5 0x00007ffff78a5e01 in dbus_connection_dispatch () from /usr/lib/libdbus-1.so.3
#6 0x0000000000460048 in message_dispatch (data=0x6cdfe0) at gdbus/mainloop.c:76
#7 0x00007ffff7b25db3 in ?? () from /usr/lib/libglib-2.0.so.0
#8 0x00007ffff7b25256 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#9 0x00007ffff7b255a8 in ?? () from /usr/lib/libglib-2.0.so.0
#10 0x00007ffff7b259aa in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x000000000040a600 in main (argc=1, argv=0x7fffffffe6f8) at src/main.c:587



Looks like an upstream bug, there's related Bug report:
https://retrace.fedoraproject.org/faf/reports/262955/
https://bugzilla.redhat.com/show_bug.cgi?id=1027055

But still I think the bug should be marked here until fixes.




This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 20 January 2014, 16:11 GMT
Reason for closing:  No response
Comment by PT. Ma. (BOYPT) - Tuesday, 12 November 2013, 11:43 GMT
this bug belongs to [bulez] . (any one rename the title?)
Comment by Tom Gundersen (tomegun) - Wednesday, 13 November 2013, 18:15 GMT
Are you using bluedevil from [testing]?
Comment by PT. Ma. (BOYPT) - Thursday, 14 November 2013, 04:59 GMT
Yes I have testing enabled.
Comment by Andreas Radke (AndyRTR) - Monday, 23 December 2013, 18:52 GMT
Status?

Loading...