Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37634 - [linux] 3.12: BCM4311 is not working with broadcom-wl or b43 drivers.

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Monday, 04 November 2013, 11:32 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 14 March 2014, 16:29 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I have BCM4311 wifi card. I am trying to connect to a WPA-PSK network using wpa_supplicant. Initially, I tried with b43 driver. I had installed b43-firmware from AUR. It did not work. I then tried, broadcom-wl driver. It did not work either.

When I try to connect to the AP using wpa_supplicant, it initially connects but then disconnects. Within that window, dhcpcd is able to acquire an IP. A log is attached.
   wl (6.6 KiB)
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 14 March 2014, 16:29 GMT
Reason for closing:  Fixed
Comment by Amitav (amitavmohanty01) - Wednesday, 06 November 2013, 15:09 GMT
I have observed that until I start dhcpcd on the interface, wpa_supplicant stays connected. However, as soon as dhcpcd starts, it gets disconnected and keeps on trying.
Comment by Amitav (amitavmohanty01) - Wednesday, 06 November 2013, 18:07 GMT
Yeah, I am aware that it is not a bug report and thus I clearly mentioned the type as support request. I think I made some progress in finding the issue. I am sharing it below. Please suggest if there is anything else I can try.

I think http://ubuntuforums.org/showthread.php?t=895417 is related. https://bugs.launchpad.net/wicd/+bug/861860 could be related too. I tried loading lib80211_crypt_ccmp module because my access point uses CCMP for group and pairwise authentication. That omitted a few error lines. I am attaching a log herewith.

My kernel is 3.11.6.
   wl (3.7 KiB)
Comment by Bartłomiej Piotrowski (Barthalion) - Monday, 11 November 2013, 11:37 GMT
Please test Linux 3.12. From my experience, broadcom works much better now.
Comment by Amitav (amitavmohanty01) - Sunday, 02 February 2014, 00:42 GMT
With Linux 3.12 also, the problem persists.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 07 February 2014, 00:14 GMT
  • Field changed: Task Type (Support Request → Bug Report)
  • Field changed: Summary (BCM4311 is not working with broadcom-wl or b43 drivers. → [linux] 3.12: BCM4311 is not working with broadcom-wl or b43 drivers.)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Field changed: Category (Packages: Extra → Upstream Bugs)
  • Task assigned to Thomas Bächler (brain0), Tobias Powalowski (tpowa)
status with 3.13?
Comment by Amitav (amitavmohanty01) - Saturday, 08 February 2014, 19:06 GMT
I will try with 3.13 soon. Meanwhile, a minor detail which I am not sure is relevant or not: I am able to successfully create a wifi access point using b43 driver.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 12 March 2014, 00:07 GMT
status with 3.13? upstream report?
Comment by Amitav (amitavmohanty01) - Wednesday, 12 March 2014, 06:08 GMT
Apologies for late response. I recently got the system working with 3.12.9-2. I recompiled broadcom-wl and tried it. However, there is another behaviour change in dhcpcd that I did not notice earlier. Earlier, I used to run wpa_supplicant as a background process before running dhcpcd. Now, if I do that I end up running two wpa_supplicant instances because dhcpcd spawns an instance of wpa_supplicant too. After observing this, I did not spawn wpa_supplicant separately and just started dhcpcd and the connection worked properly. Now that I have properly working system, I do not want to upgrade to 3.13.

Loading...