Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37626 - [devtools] checkpkg can't find package

Attached to Project: Arch Linux
Opened by Eric Belanger (Snowman) - Sunday, 03 November 2013, 22:29 GMT
Last edited by Pierre Schmitz (Pierre) - Friday, 08 November 2013, 08:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since devtools 20131101-1, checkpkg doesn't work anymore:
$ checkpkg
==> ERROR: Multiple packages found:
==> ERROR: tarball not found for package: system-config-printer-1.4.3-1

That's because makepkg makes a symlink to the package in the $startdir if $PKGDEST is set. I suspect it's caused by this commit:
https://projects.archlinux.org/devtools.git/commit/?id=27441f201c2394a991427f6a47199dd40024497b
which doesn't check if it's a symlink.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Friday, 08 November 2013, 08:57 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Monday, 04 November 2013, 12:20 GMT
There is a fix by Dave in git. But how can I reproduce this? I have build a new system-config-printer-1.4.3-1.1 package and the current checkpkg works just fine.
Comment by Dave Reisner (falconindy) - Monday, 04 November 2013, 13:52 GMT
The trigger is PKGDEST being set for both makepkg (to create the symlink to $PWD) and for checkpkg (so that find_cached_package looks in PKGDEST).

$ PKGDEST=/tmp makepkg
$ PKGDEST=/tmp checkpkg

Loading...