Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37593 - [freeciv] add sdl_sound as dep

Attached to Project: Arch Linux
Opened by Pablo Lezaeta (Jristz) - Saturday, 02 November 2013, 00:53 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 17 August 2014, 01:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
sdl_sound is need for...sound, I can't get sound unles I install that
so is a dep for give freeciv the sound to sound

Additional info:
* freeciv

Steps to reproduce:
start freeciv and wait to sound (yes in the tittle screen freeciv HAVE music)
and repeat ti whit sdl_sound intaled
NOTE: if need download a sound pack


PD: freeciv can buid againt GTK-3, QT, and SDL, maybe you want look if you can build whit GTK-3 or QT an mainting stable (you know GTK is the past)
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 17 August 2014, 01:20 GMT
Reason for closing:  Works for me
Comment by Eric Belanger (Snowman) - Saturday, 02 November 2013, 03:03 GMT
For the sound, you don't need sdl_sound. You need to configure the sound plugin to use sdl:
Game->Options->Local Client->Sound->Sound plugin

I don't here any music in the title screen even with sdl_sound installed. What sound pack are you talking about?

GTK3 is experimental, I''ll enable it when it'll be the default in the next major release.
QT is just a stub. There's no point in packaging that.
Comment by Pablo Lezaeta (Jristz) - Saturday, 02 November 2013, 04:41 GMT
no, i mean
I configure it but not was until I installed sdl_sound that I get sound in the game

Loading...