Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#37575 - [virtualbox] NAT not working after 4.3

Attached to Project: Community Packages
Opened by Zhuoyun Wei (wzyboy) - Friday, 01 November 2013, 05:03 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 03 November 2013, 18:05 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


VirtualBox NAT function does not work any more after version 4.3. Instead, it just results in CPU 100% usage in host machine and the whole Qt interface becomes unreponsive. I've tested this on a 2011 HP laptop and a 2013 ThinkPad. The latter one was bought yesterday and had a fresh new installation of Arch Linux + VirtualBox. However, this problem exists regardless of host machine (different laptops) and guest machine (CentOS, Windows XP, Windows 8, etc).

Additional info:
* package version(s): community/virtualbox 4.3.0-3
* config and/or log files etc: VBox.log (Windows XP as guest machine)

Steps to reproduce:

1. Fresh installation of Arch Linux. (Or use existing installation)
2. Install community/virtualbox, community/virtualbox-guest-iso, community/virtualbox-host-modules, aur/virtualbox-ext-oracle.
3. Install any guest OS. (CentOS, Windows XP, Windows 8) Enable "NAT" access. (This is default)
4. Launch guest machine and try to use DHCP to get networking address.
5. CPU 100% usage on host machine and the whole VirtualBox Qt interface become unresponsive.

My (in vain) attempt to debug:
1. Try different guest OS -- not working.
2. Try different host machine -- not working.
3. Disable network interface for guest machine -- working but apprantly guest machine has no networking access.
3. Uncheck "cable connected" for guest machine -- working but apprantly guest machine has no networking access.
4. Use "Bridged network" instead of "NAT" for guest machine -- working'
5. Try aur/virtualbox-bin -- not working

I am not very sure if this is a Arch Linux bug or an upstream bug. The changelog of VirtualBox 4.4 *did* mention something about new "NAT Network" function. Maybe the new function broke something...
   VBox.log (80.4 KiB)
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 03 November 2013, 18:05 GMT
Reason for closing:  Works for me
Additional comments about closing:  Reported upstream
Comment by Zhuoyun Wei (wzyboy) - Saturday, 02 November 2013, 08:00 GMT
As of community/virtualbox 4.3.2-1, this bug still exists.
Comment by Sébastien Luttringer (seblu) - Saturday, 02 November 2013, 16:57 GMT
I tried with NAT with virtual PCnet fast III and Intel pro1000 MT cards emulation. All works.
Comment by Zhuoyun Wei (wzyboy) - Saturday, 02 November 2013, 17:04 GMT
That's strange... This bug annoys me on different host machines, at different host networks, and with differnt guest machines... Once the guest started to ask for DHCP lease, the host machine just got stuck...
Comment by Ionut Biru (wonder) - Saturday, 02 November 2013, 17:24 GMT
that's related to  FS#37432  .
Comment by Zhuoyun Wei (wzyboy) - Sunday, 03 November 2013, 03:27 GMT
Before I filed this bug report, I've searched and found  FS#37432 . However it seems that the bug I encountered is somewhat different with  FS#37432 .

1. Not only Windows guests have problems, but also Linux guests like CentOS, or even Arch Installation ISO (it tries to establish network connection via DHCP).
2. Once I disable NIC for guest machines or use "Bridged Network", everything works perfectly. Yesterday I tried "Bridged Network" with a fresh installation of Windows Server 2012 guest, downloaded and installed 100+ hostfixes (>1 GiB download) with Windows Update, everything is okay. No BSOD or kernel panic.

So this may be some bugs with VirtualBox's internal NAT/DHCP server since 4.3 did some change on it (according to official changelog).

What I am wondering is that, why @Sébastien does not reproduce this bug while I encounter this bug on two different laptops (even with aur/virtualbox-bin). Maybe there is something wrong with package dependency?
Comment by Zhuoyun Wei (wzyboy) - Sunday, 03 November 2013, 03:53 GMT
The reported in  FS#37432  mentioned linux-lts so I tried it just now. Still not luck.
Comment by Zhuoyun Wei (wzyboy) - Sunday, 03 November 2013, 07:20 GMT
I've reported this bug also to upstream: